24 hour not showing on S3 Frontier

Hi @revan.tiberius

Sorry about that! Are you saying that changing that time format on the phone app isn’t reflected on the watch? Are you able to change the colors of themeable faces that way?

Correct. I have my settings on the phone set to 24 hour and have tried changing the setting from the watch face on the phone app without success.

I have just tested changing colors on a themeable face from the phone app and am unable to change the color also.

Sounds good.
Can you try triple tapping on your watch face and changing the time format in the settings there? The settings will be the last screen when you scroll to the right.

1 Like

The only option I have in Settings is below:

APD Style Classic or Dimmed

I also see the version number

Sorry AOD not APD. Typo.

Ah yes, indeed, the time format is not available there. The issue you are facing is likely related to a firmware bug Samsung has confirmed to be fix in the next version of Tizen. One way we know it can be worked around is by switching away from Facer on your watch, then back. Once you do that, the settings should transfer properly from the phone to the watch app. Can you try that?

Thank you for the info. I have tried switching between Facer and watch faces acquired by the gear store, however once the Facer watch face loads it is in 12 hour mode. I’ve tried both 12 hour and 24 hour faces from the gear store.

Have you heard of an ETA for the next version of Tizen?

After upgrading my watch to and Facer to I find that Facer watch faces still do not show 24 hour format. I’ve contacted Samsung support and they know of no issues with the Tizen OS that would cause this issue. They had me install a 24 hour face from the Samsung store and it works perfectly. I’ve also since installed Watch Maker and 24 hour faces work correctly.

Am I the only person with an S3 Frontier that is having issues getting 24 hour faces to work correctly in Facer?


Can you share a link to a Facer watch face where you see this issue? Not all Facer watch faces support the 12/24 hour format.

The first two are free and the last two were purchase.

Any update on this? Were you able to reproduce?



Any update on this?

1 Like


Hi @revan.tiberius!

Sorry for the delay in getting back to you! Looks like we missed some of your posts! :wink: We’ve identified a bug with Samsung that might cause this issue. Can you let me know if your Gear S3 has always-on display enabled? If not, can you enable it and see if it fixes the issue?

I just tried the LCARS face you linked with my S3 and was able to switch between 12 and 24h mode with no issue. My watch is set up with always-on.

We are working on fixing a bug with Samsung where some messages to the watch may get lost if always-on mode is disabled.

Thank you for the reply. I’ve tried with always-on set to on with no luck. I then removed Facer from my watch and re-installed with always-on set to on with no luck. I’m currently on 4.6.32 of the watch app after the re-install.

I find it odd that Samsung watch faces and Watchmaker faces work without issue, but Facer keeps wanting to blame Samsung for the problem.

I just tried again and now have a 24 hour clock on the face that I have loaded. Odd… Thank you for the alway-on suggestion.

I am having a problem with a face that has a functional 12/24 digital time but the selection option does not appear in the watch options in the app, only the temperature C/F is available. Any suggestions for a fix?

I had the same problem and this fixed it. Noob mistake.