Facer not showing up on Sony SWR50

First of all, I decided to put this in the Android Wear and not Wear OS category, because my watch runs on Android wear and not Wear OS.

I recently had to reset my phone to factory settings, deleting all of the apps and data, including Facer that was running on my smartwatch.

After setting up everything full again (including connecting my smartwatch to my phone), I installed and set up the Facer app from play store and waited for the Facer to show between available faces on my watch (when I long pressed the original face on it).

I’ve been waiting for it for over a week now. It does not show on my watch as an available alternative face when I long press it. It does not show up among the available face in the Android Wear / Wear OS app on my smartwatch.

I used the Advanced Settings / Resync Apps option in my phones Android Wear / Wear OS app many times during this week - did not help.

I tried to delete paring between my smartwatch and my phone and reconnect it again - did not work.

I tried to deinstall and reinstall the Facer app on my phone - did not work.

Resetting my phone to factory setting - it literally started the whole problem.

My watch is still among the supported watches both on the main Facer site (https://www.facer.io/) and in the android Facer app itself, so I have no idea why it does not work after reinstalling everything.

I’m using the following setup:
-Sony smartwatch 3 SWR50: Android Wear, Google services 8.7.01 (2590918-534), Android system version 6.0.1
-Vernee Mars Pro: Android 7.0
-Wear OS app: version
-Facer app: version: 5.1.14_101131-(101131)

I include a screenshot of my phone’s Android Wear/Wear OS app showing available faces and an area where the Facer should be visible but isn’t.


I have exactly the same issue. Did you find a solution ?

1 Like

Same thing happening for me now

I think for this kind of issue it might be best to raise a support request at:


or send an email to: