[SOLVED] How To Fix Animated Watch Face Previews

I created an animated bobblehead of Yoda where in his head bobbles around. I’m happy with my design, but the image that shows in the preview if you search for my face, or if it comes up when you’re browsing various watch faces shows Yoda with no head. Is there a way to fix this? It looks odd, and I don’t want it to discourage people from syncing it. Thanks in advance.

1 Like

I don’t know how to solve the problem , but I will duplicate the watch face. Sometime the cope one could show correctly in preview.
By the way, this watch face is really cute. I love it.

1 Like

Thank you :slight_smile: Let me know what you find

I normally create a static image for my animations. Yours may be a little different since its a free floating image instead of a full page background like the ones I have created so far. I usually have a static frame (with transparency set to 100) near the bottom of the stack. I place it in front of the background image frame. The other frames block the static frame, but that static image shows on the preview because the time is understood as 12:00:00. you may be able to have a full image with the head and spring and set the transparency to 100 only when it is 12:00:00. That may alleviate the headless yoda.

Maybe try and create duplicates of the last frame for both the head and spring and set the transparency to this:


Give that a try. Essentially should display the static image only for the 0.000 millisecond (which would never really display). That should be the same as 12:00:00 on the static preview image.

1 Like

@eradicator09 Setting the preview image to transparency of $(#Dsm#)=0?100:0$ doesn’t actually work.

But that’s one step away from a solution that does:

  • near the bottom of the stack, display the preview image at transparency of 100

  • above that layer, block the preview image with a layer set to dynamic always-on transparency:

This way the block never appears in preview, and the preview image never appears in action.

I set it to full 100 transparency as a static image on my animations. I place this frame at the bottom instead of the background.

Unfortunately it didn’t work for me. I tried it on a different watchface too. The image at 100 stays visible. I appreciate the help though.

Duplicate the first layer of your animation and put it at the bottom
here is the syntax for the transparency:


1 Like

Hmm. To see a working solution, you can check out the layers of Insidious.
I have Inspection Mode switched on for my animated watch faces.

@Facer_Official Is it an oversight that the rocket ship Inspection icon doesn’t appear in embedded watch face previews?

What are you using as your block? Is it a white shape or is it the image duplicated?

Actually, it worked! I just needed to allow it to finish publishing. I was basing it off the preview it shows during the publishing, while it’s loading everything onto the website.

A white rectangle that’s slightly larger than the spider works fine, but loads first and looks gross while the watch face is built. I ended up using a 320x320 white square.

Your spider watchface is awesome by the way! I love it!

Thank you! I’m glad this layering procedure is working for you now.

Oh I spoke too soon :frowning: It looks great in preview, but when I Sync it, the blocker image is visible

That’s what is supposed to happen:

This way the block never appears in preview, and the preview image never appears in action.

i.e., the preview image always appears in preview, and the block always appears in action.

Because the entire image isn’t animated (just the head and spring are), the static image can be seen behind his head as it bobbles.

Oh I see. Well the white shape unfortunately doesn’t work being visible for this watch face I suppose. Oh well. Thank you anway :slight_smile: