Step counter showing 0

Hi, after reading all the related topics and having reinstalled Facer and Fit (to Facer 5.1.18_101299-(101299) and Fit 2.18.12-130), step count does not work, and is always showing zero steps. When I select a watch faces outside Facer, like the ones that comes with mi Ticwatch Pro, then it´s working fine.
It seems that this issue was fixed in Facer 5.1.5, but I´m afraid it´s happening again… Thanks in advance for any information about how to solve the problem.

Hi all,

Thanks a lot for these reports - we’re not able to reproduce the issue on our side, but there does appear to be an increase of reports related to this. We are investigating this issue directly with Google to try and resolve it and will keep you posted when we have more information.

Thanks for the reply, if you need any info on my side, feel free to ask. None of my Facer watchfaces is showing steps, and the Tic ones do. Regards.

@emiliorey actually, yes, there might be something you could do to help us and Google identify the issue. Could you do the following:

  1. Select Facer as your watch face, and sync a Facer watch face that include step counts.
  2. Reboot your watch and wait for Facer to load and confirm the steps are still not reported correctly
  3. Go to the WearOS app on your phone, and in the “3 dot” menu at top right, select “Take a bug report on the watch”.
  4. This may take up to 20 minutes, but you will receive a notification on your phone including the bug report as .zip file. It will also be listed in the “view watch bug reports” option of that same 3 dot menu.
  5. Send that .zip file to us at facer-support@little-labs.com

We’ll look into it and share it with Google as well.

Ok, let´s do it! Hope to send it to you later :slight_smile:

Ok, sent. One little thing. As I reboot the watch it seems I have 16 steps showing in the screen… Very strange, I will take a look in the next few days… Thanks and I hope this is useful for everybody! Emilio.

Oh - so maybe it worked after a reboot? Can you check if the 16 steps match what Google Fit shows on your watch?

I have ticwatch and zero steps. I’ve resetted both watch and phone, still nothing. What can you guys do to help me?

I am having this trouble now as well. Everything is updated, only an issue on Facer Faces. Fit shows the correct counter, other faces show correct counter.

I have a ticwatch pro and I’m experiencing the same issue. @Facer_Official I believe this is a watch specific issue based on those who have said what type of watch they are on.

This seems to be an issue having two trackers. The watch tracker and Fit. When I turn Fit tracking off, the step counter (though not very accurate) starts to track. Using Fossil Gen 5.

Fossil Gen 5 here too. I have the counter work on some faces, but very few. For instance, Retrofuture 5 consistently works for me. But on none of Mhobold’s faces. Thinking it has something to do with using WearOS complications versus not. Just tested it by installing another random face with WearOS complications and that one counted fine too, so I think tw882003 might be onto something regarding the two trackers thing. And I have no desire to turn off my Fit tracking, unfortunately.

I thought Fit is where Facer is getting its info for Steps.
I don’t mind turning off Fit as long as Facer info works somewhat accurately for steps, calories, and BPM. Is the issue Fossil Gen 5 specific? I have Gen 4. My problem with step count is intermittent: not working one day but 24 hrs. later it’s fine, so as soon as I get ready to email Support, it starts working.

My mistake, I’m on Gen 4 Explorist Q, not Gen 5…so definitely not Gen 5 specific.

TBH, I’ve had this problem ever since I started using Facer, always with the step count. Any time I searched for a solution, the threads would mention a WearOS update that borked Facer integration.

Ok so maybe I was wrong on the whole specific watch thing. Could this be a simple issue of facer trying to read And write the steps file, instead of just read? But then why aren’t there more people reporting this issue? Gonna hook it up to my computer and look into it. @Facer_Official I think there needs to be a sort of collection on here of device, os version, and the version of fit and facer to get a good read on the situation.

Update: my bug report shows 1 of the services had 267 minor faults

Update 2: If you guys want my log then I can email it, just let me know

Well I can say I’m using gen 5 with all the latest software and apps. Still having the issue unless I turn off fit tracking which to me defeats the purpose of a wearOS watch

Hi @tw882003 - can you share more details on what you need to do to fix this issue? What do you mean by “turn off fit tracking?”

All - this is unfortunately a bug with WearOS related to Google Fit account management, which has been confirmed by Google. We are working with them to find a workaround so we can address this issue without a need for an OS update on their side. Stay tuned!

1 Like

Yes, I go to Google Fit on my phone. Profile > Settings > turn off track activities a s it seems to be tracking at that point. Or at least arbitrarily updating on the face

Urghhh… It was working when I decided to take the dive and bought three (!) watch faces (on September 17th) and then it broke the next day. Same thing. Zero step whenever I switch to a new Facer watch face. Take gazillion years to read heart BPM. It has been broken since 18th for me. What a bummer. Doesn’t inspire confidence in purchase, does it?