Step counter showing 0

I have the same issue on my Huawei Watch 2 (linked to Galaxy S9). Everything is up to date and both watch and phone have been switch off/on since their updates. Wear OS faces count steps, in fact everything else counts steps, it’s just staying at 0 on all Facer faces I have tried (about 7 so far, all from different creators).

Hi I have the same problem I have a lg sport watch and the step count always is 0, I try with a lot of faces and the result is the same 0 steps but in Google fit show the steps.

Hi! Unfortunelly the issue is still ongoing. Facer team is working hard to fix it, but depends of Google and the Fit team to make some changes on their side… They will fix it, no doubt! Meanwhile, remember your are at one finger swipe to the Google Fit activity info in wear os…

Of note, if you have a watch face that uses Google Fit data, not the built in steps (moto body, really) then the steps work… Built in Planetary 2.0 will work if you change the complication to Google Fit Steps

1 Like

@colin.trost that’s correct. The issue today is for Facer to directly access the Google Fit steps data. That’s the part that stopped working after a Google update around January 28th. Accessing Google Fit steps data via a WearOS complication works fine.

@Facer_Official is there a fix in the works? Or is there a workaround available? Currently my steps are only showing zero for 2 days now (Huawei watch 2 sport)

Same problem on my Summit 2 and Sport. No matter the watch face…

Any news on a fix? I’m using a LG Sport incidentally

Hi all! This is now fixed in Facer 5.1.5. More info here: [FIXED] Step counter not working on WearOS watches

1 Like

using 5.1.11 and step counter still not working.

Thanks for the report @dgrobe2112. There appears to be a new issue introduced by a recent WearOS or Google Fit update. We’re investigating with Google.

Still not working on my tick watch pro. Uninstalling for the time being.

Still not working on my Ticwatch Pro. I’ve tried reinstalling Google Fit, still doesn’t work.

@Facer_Official Any updates on a status on a fix for this issue?
My Skagen Falster 2 wont sync steps with the updated version. Did google provide any feedback on this yet?

Hi @dusan.bucuric @milanshah @platinumtach,

Thanks a lot for your reports and sorry to hear the issue is not resolved for you. Most users have reported that uninstalling and re-installing Google Fit fixed the issue for them, but we will follow up with Google with your reports since it appears something is still wrong for some users. Thanks so much for your patience.

I had fixed the problem previously with the uninstall fix, however, the step counter began showing zero again a few days ago.

@cydneyjmiller sorry to hear that! Does uninstalling and reinstalling Google Fit fixes the issue again, or does it seem permanently broken now?

I can try on my phone but I am unable to uninstall Fit on the watch. Uninstalling & reinstalling Facer on both my phone & watch left me with the inability to sync any faces at all for about 45 min. Eventually I was able to get a watchface to work. I’m not sure if it was because I turned Bluetooth off. Currently, the watchface is displaying SOME steps but not all (i.e. 293 instead of 7,000-something). I’m not sure where that number even comes from because Wear OS, GoogleFit, & my watch all say the same number. The only thing I can think of is that it began displaying the steps from 0 at the time I got it working, not the whole day.

I also wonder if some of the issues are coming from the fact that iOS now has 2 separate apps… WearOS & GoogleFit. My issues seem to have begun when GoogleFit was released for iOS… WearOS is the app the watch goes through & GoogleFit is the fitness app. Your stats come up in both apps, though, but WearOS is not the full fitness app.

After reinstalling Google Fit it worked for a short while (2-3 days maybe), then I tried reinstalling both Google Fit and Facer, and it worked again…unfortunately also for only a few days. I really want to buy Facer faces or subscribe, but this not working properly is preventing me from doing so. I really hope it gets solved soon

Hi, after reading all the related topics and having reinstalled Facer and Fit (to Facer 5.1.18_101299-(101299) and Fit 2.18.12-130), step count does not work, and is always showing zero steps. When I select a watch faces outside Facer, like the ones that comes with mi Ticwatch Pro, then it´s working fine.
It seems that this issue was fixed in Facer 5.1.5, but I´m afraid it´s happening again… Thanks in advance for any information about how to solve the problem.