Android: Cannot Change to 24hour

I had my watchface set to 24 hour time, and every time the android app updates it resets back to 12 hour. Now, with the latest update, I cannot pick 24 hour time, because when I select the option there is no OK button, just a cancel button.

1 Like

Thanks for reporting this @DrSeussFreak, our team is working on a fix that should be available later this week.

1 Like

Awesome, thanks!

1 Like

@Gavin I’m experiencing the same issue; will this affect the ongoing syncing issues with the Samsung Gear S2/S3 or will it address only the 24-hour setting problem?

The syncing issues should be addressed by our upcoming Samsung Gear release (we’re waiting on certification from Samsung right now).

The fix for the 24 hour setting went live today, it should be 4.3.4.

I’m too…

Any fix yet? I am having the same issues.

I hate to resurrect a dead thread but 24 hour isn’t working for me. I’m on the latest version, 4.2.6, and haven’t seen any changes. For that matter I can’t utilize Celsius temperature settings but it might not be related. Any thoughts?

Same here… Every time I set a face to 24h, I get 12h only… annoying…

S3 Frontier / S8

@firstgeekdanny is this when you change the setting on the phone app? or on the watch app?


Can you share the watch face you’re seeing this on? Either the link or its name. Thanks!

INMOTION Plug is the one I’m using now, but they all do it…

1 Like

I’m seeing the same issue of only getting 12 hours when I have 24 hour set as my default. I’ve tried multiple digital faces.

Faces I’ve tried:
LCARS: Official Star Trek
Blue Tactical DTG Military v3
Super Man Style
HouseStark (2017)
Green Lantern

Just to name a few. I’m currently on on a Gear S3 Frontier.

1 Like