App Preview Not Updating

Hi @Facer_Official @Facer-Staff

I have an issue with the preview in the Facer app.

The watch face below has since been updated several times and re-published but the app is still showing the original saved state from a while ago.

The font is wrong, as are the colours of the duplicated text in the effect. There is also another line of text missing from the top.

This is the correct published version:

This one below is showing the wrong face altogether. This is the original black face that was duplicated to make the Rose version.

Should look like this:

Do I need to delete the app’s cache or reset it somehow?

Yeap, sometimes deleting the app cache solves the issue…

I’ve just cleared the app cache but this hasn’t solved it.
This makes me think that’s it’s cached upstream on the Facer platform.

I think I remember this happening once to me.

Essentially, I sync’d the watchface to my watch before saving.the design. Even though it was “live” it would land in my draft area. No matter how many times I sync’d it after it was published it still sent the old version and stay in the draft area.

I think I had to clear the cache on the watch and the app, but it was the watch side that fixed it if I remember correctly.

I’m having a problem with fonts that started today.
I’ve tried 4 different fonts on a design. I’ve used all of them here before. The current one I use frequently in my work, so I know it usually works. Each font shows correctly in Creator, in the online Preview, in Currently Wearing, in the Congrat email, and when synched. However the preview image in the phone app shows a default font. This does not happen on my designs created prior to today. It’s only today’s design.
I’ve signed out and in. Cleared cache on phone app and watch. No change.
Facer Build 5.5_100765-(100765)
Here’s the design if that makes a difference: Linlay Designs - Roses On Blue - watch face for Apple Watch, Samsung Gear S3, Huawei Watch, and more - Facer

Update: Ok, I had a chance to try another one that had been sitting in drafts. Phone app shows all previews well. I wonder if maybe my trying to sync the one pictured here via Creator in order to test it before publishing had something to do with the problem. I’ve never been able to sync from the website anyway. I should have known better. Yes, I’ve tried all the Help tips for that. It has never worked for me.

I have the same issue; watchface on phone app is not updating.

It looks ok on the website and on the initial preview screen on the phone app ( I mean the screen thar shows all my designs on a single page ) but when I click on the face so I can preview how it looks and download it, I get a grey face, default hands and text fields all showing zero.

Umm, how do I clear the cache? I can’t find an option for that on the phone Facer app or on the watch.

If you have an Android phone, you need to go to:
Settings > Apps > Facer > Clear/Delete Cache

However, this didn’t fix the issue for me.


Thanks, found it and cleared cache - like you, it has not fixed the problem :frowning:

@Facer_Official are you looking into this?

Is it a Tizen watch or WearOS?

I’m pretty sure there’s a way on WearOS to do so.

It’s not ideal, but try removing Facer from the watch and reinstalling it? If it fixes it, then it’s likely a caching issue.

@cth4242 The problem is with the preview emulator on the phone app. The watch face is fine when sync’d on the watch itself (Samsung Galaxy Watch - Tizen)

I only noticed it by chance, as I was replying to a comment and saw that the emulator was showing a really old version of the watchface.

I have had this same problem. I sent the draft to my watch during testing, and that draft image is still displaying in the app. Unfortunately, this makes it impossible for my to test the color theme function, since I didn’t have that in place when I first previewed the watch face. Dumping the cache did nothing.

Did you send it to your watch from the webpage or from your phone?

I have found that I only had the problem when I sent it from my phone. From Creator or from a watchface preview on the PC/IPAD, sending a draft does not cause the phone App to “lock” the image of the face.

Thanks for the reply-- honestly, I cannot remember if I sent the face to my watch from the webpage or from the app… probably both as I was testing things. I will be more careful with that going forward, but it doesn’t fix the current problem. Has nobody found a way to update a watch face in the app once the image is there? @Facer_Official @Facer-Staff

1 Like