Authentic digital face but digits moving!

Hello all,

I want to make my watchface look as though it has an authentic digital face, which means adding greyed-out 8s behind the time.

If I add the 8s to match two zeros (23:00, for example), it’s fine. However, the problem is that when the time ticks over to 11 (23.11, for example), the space the digits occupy shrinks and the 11 moves. This makes a mess of the watchface. It’s driving me nuts.

Anyone have any ideas? It would be much appreciated.


Separate the time elements into two (or individual digits). This is always the issue with fonts that are not monospaced.

Thanks for getting back to me. Is there a way of doing that using the tags? Or is it just by blacking out one of the minute digits using a covering layer?

I’ll bet your regretting answering my question now but can u expand on separating?!

Take the minutes for example. I can’t separate them using tags like I can the hours (the hours work perfectly doing this…#DkZA# & #DkZB#). I tried using layers that cover one of the two minute numbers but no luck.

I have a lot of digital gauges that need this treatment to look authentic so it won’t be easy, if it’s even possible.

Thanks a million for answering my question and for any help u can give me.

Take a look at my design here:

It should give you the formulas for the individual digits.

Now I get it. Wow. Gonna take some work. Thanks a million for all your help! Very much appreciated.

1 Like

This is just for images as digits, but the concept is there. I have another example somewhere that is straight time with only 4 elements. I’ll have to find it.

1 Like


Thanks for all your help. I have it working perfectly for the time and for the battery level. However I’m trying to get it to work with steps, so 1,000s or maybe 10,000s, but not getting it to work well at all. I tried altering your codes to suit but think I’ve made a mess of it.

I’m sorry for bothering you again but would you mind having a quick look?!

Tried this for the singles: $(#ZSC#-(10*(floor(#ZSC#/10))))=0?10:0$
Tried this for the 10s: $(floor(#ZSC#/10))=0?100:0$ + $(#ZSC#-(10*(floor(#ZSC#/10))))=0?100:0$
Tried this for the 100s: $(#ZSC#-(10*(floor(#ZSC#/10))))=1?1000:0$

I’ve completely confused myself!

For steps, I have another example face. I’ll have to find it.

Find my ISO101 design or my new M1N1M4L.02. They both use the single digits for steps.

Thanks again!

I had the same problem. Thanks Eradicator09!