Battery drain problems

Love the app, love the design opportunities, love the hundreds of faces at my disposal. Yesterday I was so happy. So much that I designed a couple of faces of my own and have been using one of them today. Only it’s draining my battery like you wouldn’t believe from full to nigh on empty in a matter of a few hours (Asus Zenwatch 3). The face I designed is minimal with nothing other than (digital) seconds counting and a battery percentage. I’ve switched off all the app permissions but it made no difference.

Am I missing something? I switched to a face I downloaded from Google Pay and the massive drain has stopped.


What version of Facer is installed on your watch? We just released 4.6.0 which fixes some possible battery drain issues in situations where the watch is having trouble connecting to the phone.


I don’t seem to be having problems connecting to the phone (which is a Galaxy S8+).

Ok - can you restart your watch and see if it helps?

Can you provide a screen shot (face shot) for the ‘minimal’ watch face?

I have restarted a couple of times today but it had no effect on the problem. This is the face:

Thanks! That face is indeed pretty simple.
Can you confirm Facer probably goes into dim mode on that face? in other words, do you see your dim mode (state without battery/date/seconds,etc.) when your arm isn’t raised? Just making sure Facer isn’t continuously rendering your watch in active mode.

Yes, dim mode is working as expected.

Ok - we’ll try and reproduce this on our side.

Thank you for taking the time. It’s very much appreciated.

Hi @jimikuk! Our team tried to reproduce this on their Asus Zenwatch 3 and weren’t able to :frowning: Has this happened from Day 1 from you with Facer? Or was it okay at some point, and then something happened that made the battery drain start?

I wasn’t aware of the drain with any other faces, but then I ended up designing my own because I didn’t like any of the others I tried so I didn’t really have any others up for long enough to find out really. Today I did a factory reset and then just loaded Facer. The charge seems to be holdng for longer now. I’ve turned wifi off so I don’t know how much that was adding to the drain before.

Just to update you on this. After the reset the drain problem improved. However it still drains the battery by 10% per hour. So I guess that would give me 10 hours or so on a full charge. Comparing that to a standalone face from Google Play (one called “Elegant”). That seems to drain things at approximately 5% per hour. As do most others give or take. So it seems that the Facer software is contributing to the situation.

10% per hour is definitely very high - our benchmark is around 5% per hour on most faces. Do you know if it seemed to be at around 10% per hour immediately after your reset, or did something happen that seem to have worsened things?

That was immediately after the reset. And when I switched to the other face the drain dropped to around 5%.

Possible sources of issue:

  • Check that the icon / complication for battery is for the watch (and not for smartphone)?

  • Did you originally have other elements in this watchface, that might use more battery? Can you re-create over with new design with just: battery, time, seconds, and date ?

Note: I had a similar issue when I created my first watch faces, but I attributed most of that to the watch having Bluetooth and WiFi always on, etc.