Battery levels not working

Hi Guys

This had been an on going issue since I have had Facer… very disappointed now.
The Watch and Phone battery indicators do not work on my Gear as Frontier, the Samsung gear faces work perfect but the facer ones do not.
Sometimes if I change to a Samsung one then switch back I might get lucky and one of the battery indicators may work. This is on all faces not just specific designers.

Any help appreciated, everything is up to date and have restarted all devices etc etc, in installed the app re installed. The only thing I haven’t done is factory reset my watch which I am not really fancying, I will just stop using the app and find alternatives.

Any advice appreciated


Is this the phone battery indicator not working? Or the watch battery indicator?

Both do not work!

On mine only the phone battery does not work, it has not been working properly since early last year, no fix for this issue has ever worked, or only with an initial install after which it would be stuck on that battery level.

Watch battery works properly on mine.

@Facer_Official any response?

Sorry for the delay @djholsta - Do you have version 4.2.8 of the companion app installed on your watch? Also is this happening on every watch face you sync?

Will not install the update
Yes it happens on every facer face I have but not on the Samsung ones.

WO:WO:8022 Error code

@Facer_Official might have to sack the app totally… still not joy with the battery levels and now the app has decided that everytime my screen turns off it wants to load again.

@djholsta We’ve identified a bug with Samsung that may cause the battery update issues you’re mentioning. Hoping we can fix that very soon.
Regarding the reboots - what model of the S3 do you have? Is it an LTE model by any chance?


It’s a S3 frontier SM 760 don’t think it’s a LTE model.



I’m having the same issue with the battery, also the current/high/low temps and the weather icon are inaccurate.

Samsung S3 Frontier - Non-LTE
Samsung Galaxy S8
Samsung Software (06/21/18): G950USQU4CRE9 / G950UOYN4CRE9 / G950USQU4CRE9
Facer Build: 4.6.1_96072-(96072)

I have the same issue in my Xiaomi Mi 9 with a Galaxy Watch LTE with the last beta release