Birchwood (location)

I bought a facer smartface but the location is always birchwood. I switch off/on smart watch, location on and off but it always end up birchwood…Do i have to do something on my phone (Samsung S10+)…or do something more on my Samsung active 2 watch?..pls. help/guidance. Appreciate any help…Thanks in advance.

1 Like

Not sure, but there are similar questions (and responses) under ‘Support’ …

Perhaps, first edit you question.

Change title to what the issue is: Location always ‘Birchwood’, Galaxy Active 2 (or similar)

Change forum to: Support

A very warm welcome @eugenemilana!

Have you checked that Location is turned on in the settings on your phone ( on my Samsung this can be found at:

Settings -> Connections -> Location

I hope that helps.