Bug after last update

I’ve updated Facer last night (to version 3.1.12_2077_beta-(2077)) and this morning I’ve noticed that my most selling face stopped working properly (it worked fine yesterday and stopped working after the update).
Here is the face I’ve noticed it on: Mellin - Premise Left - watch face for Apple Watch, Samsung Gear S3, Huawei Watch, and more - Facer

I have the same problem both on my watch (sony swr50) and in the facer mobile app face preview.

I’ve created a new face to test what is wrong: Facer - Thousands of FREE watch faces for Apple Watch, Samsung Gear S3, Huawei Watch, and more
and it looks like the math operators started misbehaving.
Last 5 lines on that face:

  1. #Ds# - seconds
  2. #Dsm# - seconds with parts
  3. (#Dsm#-#Ds#) - only second’s parts (here I can see the first problem - for some reason 0 before .245 is missing and the number itself is way too long (#Ds# don’t have any parts and #Dsm# only shows 3 digits after “.”)
  4. ((#Dsm#-#Ds#)*1000) - this should show milliseconds, but instead shows constantly 0, just “0”.
  5. (round((#Dsm#-#Ds#)*1000)) - this is only last one with round() above it and even tho last one shows 0 this one shows extremely long number, like “85100”.

Here you have a screenshot of my facer app with that face:

Other faces that were affected:
Whole Premise series
Whole Archer series

And much more!

1 Like

@Mellin this looks like a showstopper bug to me, thanks a lot for reporting it. We’ll look into this asap and hold the release until it’s clarified.

1 Like

Almost all my faces suffered with this new update … (mainly Watch / phone battery hand in UTC Hand).

Well, sometimes it works, I do not know what can be

You mean with 3.1.12 beta? and everything worked fine on 3.1.11?

Yes, in the beta version, which reminds me, at 3.11, it was ok

Example, this stopped working

Watch Battery
-(#BLN#*3.6) or (-(#BLN#)*3.6)

Day Week
(#DWR#-53) or ((#DWR#)-53)

Note:Asterisk (multiplication) is not appearing, but I put it, just do not match it here in the post

@Mellin @AlemaoBRA could you test again with the new beta that should roll out in the next 30 minutes? Version is 3.1.12_2092_beta and should fix these issues (and a few others)

Now, it’s okay, it’s working again.

Thanks :ok_hand::+1:

It looks like it was fixed.
Many thanks!

Thanks for the support, guys! and sorry for the temporary scare!

1 Like

As long as it stays in beta - then everything is ok.

1 Like