[ BUG ] Image Sequencer - Default Options/Non-Looping Broke

Saw a thread here:

Tried to replicate the issue and can confirm it definitely happens. I believe it’s related to the default settings, and I don’t know if it’s intended to work as such but posting here just in case it isn’t.

If users add an image sequence and toggle the LOOP off, they aren’t able to see the gif. It stops on the first frame. Toggling LOOP on allows it to display but toggling off again it won’t.

So, I switched the trigger type to On Wake instead of On Sync and it worked. Is there a way to enable this by default when LOOP is toggled off? I figured since the watchface isn’t sync’d it wouldn’t trigger the animation, but since we can simulate the On Wake feature it “works”

Am I misunderstanding how this works and is this a bug/fix?