[BUG] Updated Gear S3 Won't Sync (Stalls At 75%)

Since update gear s3 faces will stop sync at 3 quarters of the way. Unable to now change any faces at all. Everything else seems to work on watch other than facer? Any ideas of what I can do to get this working again please? Many thanks

1 Like

I have exactly the same problem. I just updated my Gear S3 Frontier to the last software version (2.2.17082261, plugin, and I also cannot sync any of my watch faces. I get that blue line that extends 3/4 of the way around the watch face, indicating 75% completion, I assume. I assume a Facer update is needed.

1 Like

Cant see any face (black screen) after Tizen update. Red sync button in app…

1 Like

From the Facer Staff:
Thanks for your patience and helpful information, everyone.

We’re rolling out a 4.3.0 build that should improve connections to Samsung watches.

One thing we’ve had success with in getting stuck with a red button after updating, is reseting your watch and pairing it again. We really hate to ask users to do this, as I’m sure you’ve got the watch set up in a particular way, but it could be an option if you are really stuck.

We’re going to keep monitoring and improving this issue! As always, thanks so much and please let us know as you encounter any additional issues.

If you do post issues, we just ask that you include:

Your Phone Model
Your version of Android (Phone)
Your version of Tizen (Samsung watches)
Your version of Android Wear (Android Watches)

1 Like

Gear S3 Version 2.2.17082261
Gear Plugin
Samsung Galaxy S7
Android 7.0
Facer 4.3.0_4445-(4445)

Das Facer-Update hat diesbezüglich nichts gebracht. Die Synchonisierung stoppt nach 75%.

1 Like

I’m also having issues with faces not loading past 75%.

Samsung Galaxy S8
Android 7.0
Facer 4.3.0_4445 - (4445)
Samsung Gear S3 Version 2.2.17082261
Gear S Plugin Version

I have tried multiple faces, restarted phone and watch, uninstalled and reinstalled app and faces still get stuck at 75% loaded.

1 Like

Hi all!

For those who are having issues with the Gear S3 and Tizen 3.0, can you share if your watch is the LTE model? We tried on our non-LTE model here and it worked okay (after a re-install of Facer on the watch).

1 Like

I am using the non-LTE Gear S3 that was just upgraded to Tizen 3.0 yesterday. I will attempt uninstall and reinstall again.

1 Like

Non-LTE model

Samsung Note8
Facer Version: 4.3.0_4445-(4445)

Still having the problem.

1 Like

Tizen, Gear S3 Frontier, non-LTE user here. Had the problem just after the update. Uninstalling and reinstalling facer worked for me.

EDIT: While it now syncs watchfaces, it will occasionally bug out and cause strange graphical issues. I havn’t been able to update to 4.3.0 yet though.


Have you tried uninstalling and reinstalling Facer on your watch? And just to be clear the issue is that the default Facer watch face shows up (this one Facer Studios - Starter Face - watch face for Apple Watch, Samsung Gear S3, Huawei Watch, and more - Facer), but trying to sync any other face from the mobile app leads to the syncing process hanging at around 75%?

1 Like

For me, the Facer logo comes up but then nothing but a black screen. When I attempt to sync a watch face, the sync runs up to 75% and freezes. The watch locks up and has to be powered down and back up again.

Facer app appeared to be deleted when the S3 did its update.

1 Like

Does this happen with any face you try to sync?

Samsung S8
Android version 7.0
Tizen version

If it helps, my Tizen software is R760XXU2CQK3

@Facer_Official, this happens with any face I try to sync. It’s like the S3 firmware update has crashed the Facer app with the S3…

I can confirm that it is not only the S3. My Gear S2 3G also is having the same problem since the update to the new companion app. Facer is no longer usable. The new update completely broke Facer.

I have the same problem even after I downloaded the latest update that says it fixed gear connection problems.

Uninstalled and reinstalled Facer Companion app AGAIN. Everything seems to be working now.


Great to hear it @toby, apologies for the inconvenience.

1 Like

We’ve been getting reports that there is something wrong with the Tizen 3.0 update itself (in other apps, not just Facer), and you may need to reset the watch itself in order to resolve the issues. We’re going to investigate on our side (we hate to ask people to reset their watches!) but if you want to try a reset, let us know if this resolves it for you.

I just spoke with our customer service team who mentioned that users have had success with the following steps (easier than a reset!):

  1. Turn OFF Bluetooth on the Watch AND the Phone
  2. Turn ON Bluetooth on the Watch AND the phone
  3. Restart the Watch

If that doesn’t work, try uninstall /reinstall. If it STILL doesn’t work, you might have to reset :frowning:

Please let us know if this helps any of you who are still stuck!