[BUG] Watch Face Won't Update by Syncing!

Hi, I have made changes on my watchface design and the latest version syncs to my watch without a problem but a very old version synced to my friends watch when I asked them to try it and the display image looks different then the final version. The link below is the most recent version though it is not syncing to others online :confused: how can this be fixed??
I have reposted this as I have not gotten a solution yet. please help if you can!

thanks

1 Like

I’m having the exact same problem with this design : https://www.facer.io/watchface/9Q16IHv94M
A user reported to me that the new design - though displaying well on the site - won’t replace the old one on his/her watch.
This seems to be a [BUG]. @Facer_Official could you check it out ?

Was there ever a solution to this? I’m having the same problem on my watch.

@elv3n12 -

I FINALLY got around this bug. These are things I tried:

  • deleted the face and re-synced it
  • deleted ALL of my faces and re-synced it
  • deleted my face history in settings
  • restarted both my phone and watch
  • uninstalled Facer from both my phone and watch, then reinstalled
  • changed to 10 different faces to try to get the problem one out of the history
  • logged out and back in
  • tried installing the face while logged out

The only thing that finally worked was installing the problem face while logged out of my account. It was one of my own designs - don’t know if this will work if you’re using another designer’s face.

1 Like

I had the same problem, time did fix it. Seems to happen sometimes when you edit a face, the “old” one is still in cache…