Can’t access premium faces

Hi
I’m using the iOS app and a wear os watch.
I created an account then subscribed to the premium service.
I cannot access the premium faces; it still only have the option to start free trial but then when I try to start a trial it says I already have a subscription.
I’ve tried removing it from my phone and even cancelling the subscription and starting again. I can subscribe again but have the same issue.
Please help!

hi! i am having the exact same problem right now too and i have already submitted my request for help but nobody replies back yet. does anyone else got this settled? please share with us how to solve this problem? Thanks!

I have paid for the Premium service and it hasn’t worked for weeks and support is not responding. Free watch faces are having issues as well.

@princess_ice and @flymypc I see you are using Apple Watches, which (totally down to Apple), do not yet allow us to do very much I’m sorry to say. All I’ve been able to do for some time now is just apply a Photo/Image to a pre laid out Face.
As for you @jumfish I do not know why you’re experiencing that problem sorry, hopefully someone more knowledgeable can assist soon.
Regardless, I welcome you all to this Community, where there is loads to learn and lots of friendly/helpful people too.

1 Like

Hi there!

If you’re having trouble accessing Facer Premium, please file a bug report at https://help.facer.io/hc/en-us/requests/new

Our team will help you there - Thanks!

1 Like

WOW @Facer_Official your support deleted my request for help! I should have screenshot the support’s name my request was assigned to! if i file a bug report now, will that be deleted too?

My faces worked for a time but now they don’t.

I have submitted several times no one replies

Give them time, there is lots going on here sorry