Can`t send/sync faces on my watch

Hi. Until the latest update I can`t sent faces to my watch anymore.

Samsung Gear s3 / Facer App 5.1.12_101073

I have uninstalled and reinstalled the app. Switch both (watch and phone) off for several times.

I can change Faces in the facer companion app on the watch. But I can´t install/sent a new one to my watch.

1 Like

Have you installed the latest version of Facer Companion for Samsung on your watch?

On your phone, try uninstalling and re-installing WearOS app as well.

1 Like

I have un- and reinstalled both on watch and phone. I have only the default watchface. Can not sent any other face.

Sorry you have not been able to solve this yet - I am all out of advice ( making sure all the correct software is installed and up to date is my limit :frowning: ); hopefully someone with more knowledge of these things will step in and give you something to try …

Try temporarily turning off Bluetooth on your phone and let the watch connect via wifi. Sometimes, and I have no idea why, even then it takes numerous attempts to get Facer to sync my watch to a new face.

1 Like

Does not work either

Can you send any faces from the facer website? If not maybe @Facer_Official could help.

1 Like

Hi @B-One - can you send us an email at We’ll help you out there!

1 Like

having similar issues myself on a Galaxy Gear Sport and the latest Tizen updates, and up to date iOS app (iphone x, latest ios) and gear app / facer watch face.

note; i can download via the 5 random but can’t push faces from iOS facer app or from website on my macbook air. removed app from iPhone and relinked to watch but still not syncing.

absolutely the same problem as mine

I vaguely remember that turning on notificatioins in the Facer phone app might help; at least it has helped some people …

Glad its not just me then. I purchased my Galaxy Watch 2 days ago and installed facer and worked well. I think since the Tizen update it has now stopped pushing faces to my watch via the Iphone. I was about to cancel my premium subscription until I noticed that other users such as yourself are having the same issue. I’ll keep an eye on this thread.

Hi everyone - Thanks for the reports. FYI, we’re currently investigating this and will update this thread as soon as we have more info.


Hi all,

We’ve reproduced the issue on our side with a Samsung S3 Classic running Tizen connected to an iPhone.

In our tests, the “Galaxy Watch” app on iPhone also crashes very regularly which seems to indicate an issue at the Samsung level. Are you guys seeing the same thing? @nelsonmandelahouse @B-One @seamonkey420.

Note that based on our tests, this is specific to Tizen connected to iPhone only. The same version works fine connected to an Android phone. Tizen works fine as well, even connected to an iPhone.

I have updated my watch to Tizen / Android Phone (Honor 6x)
Same problem still exists. No possibility to send any face to the watch.

Yes! That was the issue! Thanks for your help…

1 Like

Hi guys,
I’ve got the same issue. Tizen on S Galaxy Watch connected to iOS.
Galaxy Watch app is stable with no issues at connectivity, but Samsung Health seems to live it’s own life. Sometimes I only see message that no wearable device is connected although both BT profiles run and Galaxy Watch app respond is immediate. Then after couple of hours it refreshes itself in the backgroud.

Cool! I am glad it worked :slight_smile:

No issues connecting to the galaxy watch app. I am using the latest Tizen software with Iphone8. I have been unable to push any watch faces to my galaxy watch since the latest Tizen update. Gutted as I have just subscribed to your premium service and am guessing this is going to take a while to resolve.