Can't detect companion app

The Facer app on my Samsung Galaxy S22+ doesn’t detect the companion app on my Samsung Watch. The watch app is working fine and even the weather on the watch face is up to date. But I can’t install any new faces from the phone.

I’ve tried resetting everything, but still the phone app doesn’t find the watch app.

I’m not sure what “everything” means. Have you checked to see if your Facer phone app is the latest version? Have you tried to uninstall/reinstall the phone app?

1 Like

I have checked and both the phone and watch apps are up to date. I will try un/reinstalling the phone app.

1 Like

I un/reinstalled both the phone and watch apps and still no detection of the watch app. And now that I’ve uninstalled the watch app I can’t load the faces I normally use on my watch.

I have had to set a non facer face on the watch before and then go back to a facer face and that worked.

1 Like

I’ve tried that, too. That used to work for me, but no longer does.

I can load new faces using the Daily Mix on my watch, but only the faces that appear randomly there, not the ones I want to load from my phone.

The phone app still does not see my watch. Here are the details of the apps I have installed:

Facer App Version is, which is the latest version according to the Google Store

Watch (a Samsung):
Version (Facer for Samsung)

When I try to install faces onto the watch I get this message: “Uh oh! Can’t connect to your watch” But the phone and watch are connected – I get notifications, the weather information is up-to-date, and I can install new faces from the Daily Mix.

I’ve uninstalled and reinstalled both the phone and watch apps. I’ve rebooted both the phone and the watch.

I’ve enjoyed using Facer for several years, but this breaks it.

Which model watch do you have?

I have the original Galaxy Watch connected to an Android phone. I encounter companion App issues when I try to sync a face from the Facer App on my phone.

The following works for me ( for what it is worth ).

Restart the phone and watch and wait a few minutes.

Connect the Samsung watch app to the watch and wait a few minutes.

Start the Facer App ( and wait a few minutes ). Usually, eventually, the Facer app will indicate that it is connected to the watch.

And then I DO NOT try to sync a face from the APP ( if I do it breaks the connection ). Instead, I log in to my Facer account in a browser on my PC and sync a face from there. It can take a minute or so but the face will then turn up on my watch. The same might work from a browser on the phone but I have not tried it.

In my case I assume that the issue is caused by the fact that the Galaxy Watch / Tizen / Companion App version are now “ancient” and problems are starting to come in.

I don’t know if any of that will help, your watch and issue might be different, but it could be worth a try.

Thanks, I have the 2018 watch, so I may be having the same problems. I’ll give your solution a try (but Facer needs to fix the problem it apparently created).

1 Like