Can't download to my Samsung S3 from my computer

Nothing happens when I try to download a watch face (my own or a published one) from my Mac to my Samsung S3. The “send to watch” icon turns into a check mark, but nothing happens on the watch. I can send faces from my phone (S8) to the watch, so I ended up eventually publishing my face just so that it would be accessible on my phone. (The Creator site refuses to display on phones, not even enough to show your drafts so they can be downloaded.)

Yes, I tried uninstalling and reinstalling everything. And switching away from and back to Facer on the watch.

@ucblogo make sure you are logged into the phone app with the same account you use on the web. Let me know if that solves it!

Nope. I’m definitely logged in on my one and only account on both, and I still can download only from the phone, not the computer (browser).

Can you check that you allow notifications from Facer on your phone?

I have actually never had this work for me…
Facer is installed and working on phone with notifications allowed

Ditto, notifications allowed on phone, but I don’t see how that’s relevant since the problem is on my computer.

+1 for this issue.
Gear S3 Frontier, Galaxy S6 Active.

Rebooted watch and phone and it still doesn’t work.

Last night I opened the Gear app for the first time in a while and there was an update available (allegedly). This morning, it worked!