Can't get watch face on my watch

When I try to apply a watch face to my LG urbane 2ND edition I keep getting “syncing please wait” and then after like 10 min it just goes back to the standard face everytime…

Close the application on your phone and restart the watch. I usually get this error when syncing from the browser as well, so to avoid that I just publish in browser to save, and then sync from the “my designs” in the app, and it does it in half the time.

Exactly the same for me…Had numerous faces on my Moto 360 2nd gen and all of a sudden I couldn’t send any new faces to the watch.
Thought the watch had too many faces so deleted practically all of them and still get the syncing issue

Even faces I had previously installed wont now sync across…syncing please wait

Restarted watch and phone numerous times…

Can send faces across from standard android connect app

Has the facer app been updated recently preventing the faces to be sent?


I am also encountering the exact issue from like couple of week, I am unable to set a new watch face, it keeps spinning on syncing … please wait… Facer please help ! I love your app and watch faces.!

Hi all! Thanks for all the reports. Can you share the following information for our team to investigate:

  • Version of Facer
  • Version of Android and Android Wear
  • Model of phone
  • Model of watch


Hi, Thanks for looking into this.

  • Version of Facer - 2.5.2_1013
  • Version of Android and Android Wear - Android 6.0 & Android Wear
  • Model of phone - Moto X 2nd Gen
  • Model of watch - Asus Zenwatch 2

Thanks @Xyne! Does uninstalling and re-installing Facer fix the issue by any chance? Obviously not the ideal solution, but knowing if this does the trick may help us identify the issue. Thanks!

I’m getting the same issue with my Fossil Q Founder watch. I created a different post on this as well before seeing this one.

My details are as follows

  • Version of Facer - 2.5.2_1013-(1013)
  • Version of Android and Android Wear - Android 6.0.1 & Android Wear
  • Model of phone - Sony Xperia Z3
  • Model of watch - Moto 360 2nd Gen 2015

As previously mentioned in my earlier post the app and phone use to work perfectly. Not sure whats happened.

In a way I’m glad other people are experiencing the same issue as I thought I had done something wrong


Is there a specific date it started happening for you all? or after a specific event?

Hi @Facer_Official

It’s been like it for me for a little while…couple of weeks I’d say…but only just reported after multiple uninstalls and restarts… like I said I wasnt sure that my watch was full and couldn’t take anymore

Its only that I see @djsunkisd comment about their issue I registered to also add my symptoms

My watch spins continuously on Syncing please wait…until to touch it and it shows the existing watch face

Im happy to test any solutions you can think of


Hi Team,

Sorry about the delay ! Just went out of my mind. I tried to uninstall and re-install but does not fix the issue. Any app updates team?

Cannot recollect any specific date - Just out of mood felt to change the watch face which I always do through Facer and bam this issue.

Uninstalled-Reinstalled the App, Resynced the apps on my watch - Same issue.

Hi @Xyne & @Tommo14,

So I’m trying to look into this issue but I can’t seem to reproduce it on our side. But, lets first try some things that might resolve it.

Here is some stuff that you can try:

  • Update the app to the latest version, this should be 2.6.0.
  • Reinstall the app if it still occurs. But you’ve already tried this.
  • Restart your phone and your watch.
  • Confirm that your bluetooth connection is enabled, and that you are connected to the watch with your Android Wear app. Also, on the same note: confirm that airplane mode is not enabled. This is probably not likely though.

If that still doesn’t fix it, please let us know.

Sorry for the inconvenience.

Just downloaded facer on my sony sw3 and I’m having the same problem… Syncing but nothing happens

Hey @Cburke,

Are you still experiencing this issue? If so, could you check out the answer I gave above, and see if that fixes it. If it doesn’t please report it back here so we can try and fix this for you.

Hi Tim !

This is now fixed, not sure how probably the latest update did it!

Thanks for looking into this, appreciate it ! Fan of Facer :smile:

Hi Tim, I too am having trouble syncing faces over to my watch and have tried all of your sugesstions. I have also been having a lot of trouble with the Creator. It started about 3 or 4 days ago while I was designing a new Christmas themed face. It’s almost like the Creator gets stuck while loading. Most times the layers panel on the left will not appear at all and I am unable to click on anything on the screen. Then there are other times when it all appears to load ok but then the Creator jumps back and forth from 12am to 11:59pm on the Time Machine and again I am unable to click on anything. My only option is to exit the Creator completely. This is happening on new designs and also existing ones too. Since this happened, I have not been able to sync any faces to my watch, even ones that are not my design.

My details are as follows

Version of Facer - 2.6.1_1107-(1107)
Version of Android and Android Wear - Android 6.0.1 & Android Wear
Model of phone - Samsung Galaxy S7
Model of watch - LG Watch Urbane

On my laptop I am using Windows 10 and always use Chrome but I have also tried the Creator in Microsoft Edge. Unfortunately it is doing the same thing.

Please Help!!

Cheers, :smile:

Hi, I had exactly same problem and it was because of “Messages for Android Wear” app. Maybe you have some app that want to sync very often and making problem.

I’m also having this issue

Gs7 with haueii watch