Can't upload - copyright infringement !?

Hey all,

I’m unable to upload a new design… tried twice.

Second time round, I decided to copy the sharelink function to see if something’s up with the facer platform showing recently published designs (or maybe my poor bandwidth)… Still no joy in my ‘recently published’ dashboard… so pasted in the link URL and I get ’ This content was automatically removed due to suspected copyright/trademark infringement.’

I’m a little confused.

  1. This is an original design, drawn from scratch.
  2. It’s (very close) to a design I published earlier in the year on Samsung’s GWS, wholly owned by me, and…
  3. It’s my design and my brand! All original assets…

Perhaps as irritatingly, while I can’t upload an original design under a legitimate brandmark…

  1. Facer is littered with ‘Fake’ brands - largely why I recently realized there’s no point in submitting anything in the ‘Luxury’ category, as my little brand can’t compete with fake Ferrari’s, Tags and Lange, L&V et al…

…and I get a message re IP!

To add a little humour to the matter, I posted a comment on IP only a few days ago, go figure…

So, please, someone help me out here. Am I missing something?

Thanks for your help.

Richie Mac!

1 Like

I believe it’s because you used the name flightmaster. That’s a trademarked name and it will get instantly flagged. You will have to change the name. It sucks but hope that helps.


As @Orakix said, “Flightmaster” is an Omega watch name and is no doubt owned and registered by them. When faces are first upload, an automated check tries to catch infringing faces by looking at the name, description and content of the face. It is constantly being improved but it is not perfect of course; it misses some and occasionally falsely flags others. If you ever get a rejection with no obvious cause you can appeal and have the face restored if it was an error. This one though is probably due to the name.

OK, thanks so much… I had no idea. Seamaster, for sure, but didn’t know they’d employed the ‘master’ suffix. Thanks again.

I had one that was false flagged as a Hamilton, it was the one time that Facer support was actually quite speedy in responding to me about anything and and they quickly restored it. The face had absolutely zero resemblance to any Hamilton, but it hadn’t occurred to me that it might have been the name that triggered it. Hmmm.

Thanks Mike, Now aware for the name/TM… Thanks for your help. Will do a google search before posting a new design with a descriptor using a ‘that-will-do’ product name. Cheers.

1 Like

Thanks KV, now aware… thou still a little bemused by all those watches on Facer with blatant logo use… I might design a ‘Bolex’ Homage piece…:wink: The new watch with the sunburst effect looks great BTW. Cheers.

I’ll go you one better. I was working on a face and using the #ZMANU# tag to put the brand name of whatever watch it was running on directly on the face. I was switching between watch brands to see how it worked in the creator and if I put it on a Samsung that’s what it would say. When I was satisfied that it worked OK I uploaded it. Problem was, it was showing a Fossil watch body and when I uploaded it, Facer’s filter flagged it and took it down. USING THEIR TAGS! I complained and only heard silence from Facer. Like you I, ended up remaking the watch face and reloading it making sure it was set on TicWatch and it went through without a problem. A couple days after that I noticed that the Facer Creator would no longer let any watch body you are using to make the face slip through into the publishing stage. You have to always change it from the TicWatch E to what you want on that final publish page.