Chrono works perfectly on Facer Creator Simulators but not watch

After days of design work and checking results on the Facer simulators I have been stymied by the fact that my stopwatch (chrono) face works perfectly on the simulators but does not work on my Galaxy Active 2 watch. The design looks nice but just sits there ! :frowning:

Can’t get the chrono “start/pause” to work so can’t start the timer going. (Yes the Action is correctly set to “start/pause”). The true/false activity status always remains “false.”

Is this an Active 2 watch issue or is there anything I need to do to enable screen taps on the watch as no taps, tap&hold, or double-taps seem to work on this face, although they do if I remove the stopwatch layers from the overall design. (The stopwatch will be enabled by a tap on the main watch face but for now nothing has been set up. I just put the stopwatch layers over the main watch while I work on the basics.

This face is named “KB002.2-Active” but is not published as it is not yet working fully. I have Inspector Mode enabled however. For help do I need to publish for someone to see the face?


1 Like

I’m not aware of any Active 2 issues.

Just a thought but are you signed up to the Creator Pro subscription? ( I think you need that to be able to create a face with the chronograph feature. )

Yes I am a “Pro” subscription member. Probably couldn’t even access the “complications” if I wasn’t.

Strange that the Facer simulators work perfectly with my design but it is dead on arrival at my watch. Everything is there but I can’t activate the chrono action.


Any ideas on what I might look for on my Active 2 watch? I’m not having any kind of similar issues (or any other issues for that matter) with anything else, so stumped as to what might be the cause.

1 Like

I just downloaded 2 published (and apparently working according to comments) chrono faces to my watch and neither one of them worked. They did the same thing as my design… that is nothing but sit there!

So it is apparently my Active 2 watch. I thought that maybe the Galaxy Stopwatch had to be running or paused, but that made no difference. I hid the Galaxy Stopwatch App (ie, essentially uninstalled it) but no difference, and then I re-enabled it but did nothing with it and that didn’t help either.

Ideas, anyone?

1 Like

Sorry, no. That is very strange.

If you let me know the links to the 2 published ones you tired I will install them on our Active 2 and see if they work. That will help work out if it is an Active 2 issue or something else.

Mike I GREATLY appreciate your help.

Here is one sample I checked…
[TOMAJA Interactive Stopwatch] Microchronometer Analog & Digital

I can’t find the second one but here is my face for you to look at. I believe I have done the same essential things that the model above listed did too…
Ken Burkhalter - KB001.3-Active - watch face for Apple Watch, Samsung Gear S3, Huawei Watch, and more - Facer

I look forward to hearing what you learn.

Many thanks.


1 Like

Mike -
I just added a face ‘hot-spot’ to toggle VAR_1 and a text field to display the VAR state.
The hot-spot is at the 12 o’clock face position. On the Facer simulator it works perfectly toggling VAR_1 every time the hot-spot is tapped, but does nothing on my Active 2. No kind of taps will cause it to do anything.
Looks like something is going on with the watch. Mine is about 3 months old and its SW is all up to date as far as I know…


1 Like

I’m not sure if this is good or bad news but the Tomaja face above works correctly on our Active 2.

I can’t load your face - I suppose you have not published it yet.

I didn’t publish it as it is not fully working (per the publishing instructions). Is there a way to publish without publishing (so to speak) That is so you can see it but not the public to save confusion.

Also your finding is good news as it means that the solution lies at my end and thus there are no time delays in scheduling a bug fix. [:-)>

That said, any thoughts at where to look on the watch?

All other faces work ok. I’ll load up a regular face (not a chrono) and see if the VAR toggle zone works OK on them and report back.

What happens with the link to my shared face?

I can access it OK as an Anonymous browser so I would have expected you could too. That is the way I always test my web site designs to make sure I am not seeing things differently as the ‘owner.’
Is there any way to get you access if for some reason my link doesn’t work right.

Here it is again as plain text so you can copy/paste in case the link was corrupted…

To keep the forum from making it a link automatically I have added an ! to the ‘www’ Remove it.

1 Like

Thanks for the link, I’ll try it out in the morning - off to sleep now :sleeping:

Got it!
I uninstalled Facer on both my watch and my phone and then reinstalled it.

That made everything work perfectly.

Then trying things out I discovered three questions…

  1. There seems to be major conflict between the desktop and web use of “Creator” which has resulted in much confusion as there appear to result multiple DIFFERENT versions of the same thing. As I worked I’d fix something only to discover it was gone later. I finally discovered that the desktop and web Creator versions seemed te same as I was working on them but weren’t.
    I finally trashed my desktop version and concentrated on the web App and I think finally have things straightened out. Can you simply explain the overall relationships here and is there any reason for me to use anything other than a central web App to design? I had assumed the web and desktop versions were synchronized.

  2. In the initial struggles I kept encountering that Facer was displaying a scaled down image of the current face along with tiny icons on the left/right of the screen with “<”/">" arrows but they did nothing. To get out of that mode I had to press the lower right watch button several times to get back to the full face. After the reinstall of the Facer SW that same scaled down face appeared once and the left/right arrows took me to old/new Facer screens (which was WONDERFUL as my major complaint of Facer has been that I can’t easily change screens unless my phone is near and I take extra efforts). BUT then I lost that feature just minutes later and can’t seem to get it back! :frowning:
    How can I trigger it again and how does it fully work (ie, link to documentation) I loved it.

  3. Finally my Chrono is HANDICAPPED by the fact that the watch dims it after my normal 15 second timeout. That not only dims the image but freezes the images making a timer rather useless. Is there any way to force the watch to NOT dim while the Chrono is running (ie, ($VAR-2=1?#NODIM#: )
    If not possible within the watch OS then an alternative is for users to set watch to never dim and then for Facer to have a timeout parameter which coders could then use to change the transparency, from time of initial display, on a black full mask, or not, if no dimming was desired.

1 Like

No need Mike. It works now (see next post).
Here is a link to published face…
Ken Burkhalter - KB003-Active w Chrono - watch face for Apple Watch, Samsung Gear S3, Huawei Watch, and more - Facer
ken :grinning:

1 Like

I’m glad you got it working ok! Well done for persisting.

As for the desktop version - I only ever use the Web version.

And to change faces on your watch, tap the screen quickly three times on the right edge of the screen.


I’ve discovered the web version feels much faster than the desktop as it doesn’t have to up/down load everything all the time, as it has it.

THANK YOU for the tap 3-times and enjoy tip.

I have NOT seen that anywhere. That is a SUPER feature and Facer should get it in the documentation.
I never figured out what I did to get into that phase. I know I tried 2 and 4 taps but must have been at the wrong time.

You didn’t respond to the DIM timeout issue. I note that Samsung seems to have a “stay on” feature on their Apps so there must be a hook somewhere in the OS. I assume you just haven’t found it yet. :frowning:
Any hope or won’t Samsung share the goodies (kinda sounds like what happened with Microsoft until the courts told them to start being anti-competitive!

1 Like