Complications never work for Facer Premium

I am new. I have not been able to see any complications work of apple Watch Series 7 or 8. My daughter and I have both tried fixing every setting mentioned. Reset both phone and Watch multiple times.
The face goes to the watch but when any icon is touched it shows a blue rectangle that says open app and browse to sync faces and complications

Anyone know how to fix? I have emailed several times and am still waiting.

Hello and Welcome!
Which complications are you having this issue with? Is this happening with a free or a premium watch face?
In addition to your email, see if this page helps.
Please use this support form to report your specific problem. It may reach support more quickly than email.

Thanks, I’ve tried all of that. They replied and said this is a known issue. But no offer of a refund.

It’s premium. The face goes to watch but complications will not work

Facer does testing and approval on premium designs to make sure they work as described. Therefore, most likely there is a permission missing someplace. If your settings are as shown on that Help page, I don’t know what the problem could be.
Send a support request using the form. You will receive a Ticket # to use if you have to send additional messages.

Edit: I was replying above from email and did not see the message above your last one. It’s a known issue on WearOS, but I don’t think it is an issue on Apples. I’ll ask around and see if other Apple owners are having the problem.

Thank you. I felt it had to be permissions too. But Facer told me differently. We have Apple series 7 and 8.

Could you post a link to a face that does not work for you? If you can I’ll see if it works for me …

That sounds like normal expected behaviour.

Facer complications do not link to other applications. Tapping on one asks the watch/phone to update it, that’s all it does - it will not launch any applications. I don’t know why Facer has added the message about opening the App, etc… But, the message does not indicate that there is a problem.

Of course, tapping on Apple made complications will often result in an application being launched - just not Facer complications.

1 Like