Coupons do not work

I’m using a OnePlus 7t and a 42mm Galaxy watch. It doesn’t matter which face I choose, the provided coupons always state that they’re invalid.

Yes I select the correct country. What else am I missing?

1 Like

I’m sorry I have never used coupons so I can’t help - hopefully someone else will jump in with an answer.

If not, you could raise a support request with the Facer guys:

or email

I hope you can sort out your issue.

Well on the bright side, it appears that I’m the only person who is having this issue…

1 Like

One came up on my phone yesterday, for an AVI-8 face, I also got the invalid message when I clicked on it.

Exactly the case. I’ve tried on 5 or 6 faces now, and wash time I had the same result.

1 Like

The app is basically useless at this point. Every click tries to open the browser, and takes me to the Galaxy store. I can’t even enter coupons (which don’t work anyway) at this point. I’m pretty frustrated with Facer, and nearly to the point of uninstalling.

Are you able to select and sync free faces from the App? Is it only paid faces ( and coupons ) that you are having problems with?

The reason I ask is that it occurred to me that my problem might be because I changed my Goggle password and did not update it on my phone. If you are having trouble buying faces then you could check that you are able to buy apps from the store.

Ok, having updated my Google login, I was able successfully access and apply the latest promotional coupon. So either the fixing the login solved the problem or there was some other issue that is now resolved. Anyway, I thought you might like to know in case you want to keep trying to solve your issue.

I’d like to give this a try. I don’t see any options for inputting Google logon information on Facer though. Where are you seeing signing credentials? I only see the option for my Facer login.

Not in Facer. Go to Google Play Store and login there. Or maybe even just login to google from the browser on the phone. I assume you have already setup an account on the play store (?).

I don’t know if any of this will help but best of luck!

From the OnePlus, it’s seemingly very tough to get this resolved. I’m logged in to Google, everywhere. The Galaxy Store app has no place to sign in or to use coupons, the Samsung app keeps signing me out.

After signing in to everything again… Tried the coupons again… Still no luck! WTF am I doing wrong?

The coupon code inserted spaces at the front and back of the code… Causing it to look invalid.

The issue appears to be solved. Thank you for your assistance.

1 Like

I’m glad you got it resolved!


My iPhone 7 not read the QR code how to solve that thanks?