Creating face for Apple watch

I wanted to try out creating an apple watch face, so I prepared set of 624x780 px photos and started uploading them one by one.
After 4th one, when I tried to load another (5th) it stops and I can just see that loading circle in the top right corner.
Same goes to changing face’s name - it’s currently “My Watchface” and I cannot change it to anything else. When I try I get that loading circle again.

I tried leaving it loading for an hour, but no success - still spinning and nothing new has saved.

Just out of curiosity, which browser do you use?

This happens to me when I use MAC / Safari, now I can only use Crhome.

I already cleaned the cache, reinstalled and it does not work (only with chrome)

I do use Chrome.
Version 57.0.2987.133
On Windows 10.

got it…

Well, I guess in that case, only support can help.

But try another browser, just to get the doubt

Tried on IE and not figures - It didn’t work.

I’ve also updated my Google Chrom to version 58.0.3029.81 and still nothing.

Here is a link to my Apple face (to what I managed to do at least): Facer - Thousands of FREE watch faces for Apple Watch, Samsung Gear S3, Huawei Watch, and more

Support… ?


We’ll have our team look into this and update the thread. Thanks for the bug report!

Hi Mellin, I’ve had similar issues, I don’t think it’s the name I think its the file size try sending a low res file and see if it works just as a text and if it does work back from there, let me know how you get on

Thanks for the idea, I will check it out when I will have some time.
But there is also problem of changing the name of the whole face…