Custom Font not Loading in Facer Creator

I made a custom font on FontStruct (A free font creator). After uploading it to Facer Creator, the font won’t load properly when I try to use it. It keeps turning into a font that looks like New Times Roman. I wasn’t able to upload the link for the font, so here is a picture:

I am also including a screen recording to show how different the fonts look from each other:

Hello and welcome!
Facer Creator does not read some custom fonts well. It is best to stay with those offered in Creator or to find something similar offered at reliable font sites.

Ok, but I want to use a custom font. Do you know any other reliable apps/websites for creating fonts?

Most likely you will have the same problem with anything “custom” and new. If I were you I would just look for something similar at a font site.

I tried looking online on various websites for a similar font, with no luck.

I ran into a similar issue when I needed to use a custom TTF font, using a free font I downloaded from somewhere. Creator would just not take that font no matter what I tried.

From curiosity I ran a test: I changed the font’s format from TTF to OTF, then I changed it again from OTF back to TTF. Interestingly it finally worked for me, but I can’t tell if it would work for you.

I think I used Font Converter | CloudConvert to convert.


I created a custom font for free using this website.

I didn’t encounter any issues. Ive only created a custom font once though…its time consuming!

1 Like

Tried, doesn’t work. Thanks for the recommendation, though!

I just created my account; looks like I have to draw the font by hand then scan it. Since it’ll take time, I’ll update this thread after making the font and attempting to upload it.

Thank you for informing me about this!

I develop mainly using my tablet (samsung s8 ultra) and used android app “AddText” as my image and text editor.

I basically opened the template png in this app then placed my characters onto the template.

If you are a pc user, you could do similiar in GIMP or photoshop or any graphics program. Or print the template and draw by hand.
As you can see from the template, i only catered for digits and separators

1 Like

Heres an example template.

Thank you for your advice.

I see you only filled out the numbers and some symbols. Even though that is all I need for my watch face, I noticed that when I was trying to import the font for the numbers to Creator, it won’t even load the font. So I also had to fill in all the alphabet to get it to import. Is that only me, or have you experienced that too?

You have to use their templates. Try downloading the Minimal Numbers first and see if that works for you. You can add additional characters by tapping ARBITRARY CHARACTERS button. I didnt have any issues when i last used it.

Generated Font must be .ttf format too

I just tested it with that example template i showed previously. When i download the font (selecting the .ttf link) it saved it as filename.ttf.otf
I renamed the file, removing the .otf so that its .ttf only. Then loaded as custom font in creator.

I’m currently filling in the template, I’ll see if it imports properly after I’m done.

Thank you for the clarification.

The font finally loaded! Thank you so much for your help!
Screenshot 2023-12-07 6.56.53 PM

1 Like