Custom fonts no longer supported?

I’ve tested about 30 .ttf fonts in the past month and none of them render past the editor. I suppose my real question is, should I wait for a fix or continue publishing with the house fonts?

To see if it’s just me, here’s a test face with a variety of fonts. Which ones are visible on your end?

1 Like

@pandaKrusher Hi! Could you send us an email at We’ll try to help figure out what’s going on.

1 Like

When the issue is resolved, please post back here. I seem to be finding more fonts with problems. Some worked at one time but now show up as the default serif font in the above image. I don’t remember all of them except the most recent, “Fat Marker”.

1 Like

None working (they all looks the same)

Most of mine still work. I’ve come across about 5% that don’t work in Creator and/or have reverted to the generic on older published designs. Can you be more specific?

I’ve noticed that recently Creator inserts a “%” if a custom font does not have one, so that’s good, but I wonder if something changed when that update was launched.

New creations with custom fonts are not working for me either. My earlier designs with custom fonts are still working but this was noticed this earlier this year (about two updates ago to my knowledge). Tried about 6-8 fonts, none of them translate on the watch and funny enough, after publishing the watch faces with the custom fonts, there are serious issues with the layout. For example, the time and date are out of place, like way out of place. When I attempt to reset them, they go right back into some mal-aligned position. Hopefully there will be an update to address this soon!


Their shit is broken. Don’t use custom fonts.


I have no problems so far with custom fonts. Don’t really have much else to add to this topic but, after reading the previous post I had to mention it. Sorry things aren’t working out for you though pandaKrusher

@pandaKrusher Sorry about this, we are continuing to look into this issue and hope to have an update soon.


@pandaKrusher We released a fix for this issue today. Could you try again on your side? Note: the fix will only only to newly-added fonts.

1 Like

Hey it works! Thanks for fixing. Since it only works on newly added fonts, I’m guessing the only way to initiate the fix is by starting already-created watches over from scratch, since duplicating a face carries the existing fonts over. I couldn’t find a way to delete a font. No biggie.

UPDATE: found a workaround. Renaming the font locally and re-uploading will enable it. No need to start from scratch.

1 Like