Dim Mode Timeout Bug

I recently downloaded Facer onto my new Samsung Watch 3, and I noticed that Facer doesn’t respect the chosen system screen timeout setting. I have the watch set to go into always on / dim mode after 15 seconds, but Facer watch faces always go into dim mode after just 5 seconds, regardless of the system setting.

This makes them practically useless to me. Is this a known issue?

Hi there, Facer does have a quick trigger to dim. Apparently it is regardless to the hardware. There have been suggested a couple of 3rd party apps that can be used on the watch to change the time before Facer goes to dim, but I have not personally experimented with any yet. I think I asked this question in the forums myself earlier this summer, so you can probably search to find the apps that were suggested to me. Maybe one was called “stay it” ?

Thank you for responding. I saw a couple of posts talking about the kind of apps that you’re referring to, but I believe that they’re all for Wear OS, and not for Tizen. So, that can’t help me. If this is a known issue, then the developers of the Facer app should fix it.

I know that it doesn’t have to be this way because I also have the WatchMaker app installed, and I can set it to follow the system settings, or to stay awake for longer than the system settings.

I remember one more thing about Facer on Tizen ( I never use my Frontier anymore) but if you triple tap then scroll all the way to the left there is a settings tile that has a couple of options of how dim is handled. This is not available on WearOS so I’m not entirely sure what your choices are there, but I remember it mentioned here before.

I used Watchmaker for 2+ years before switching to Facer. I really like this platform and community, but the ability to set the timing of dim is definitely something I miss.

This has been an EXTREMELY frustrating issue. I can find NO Apps to fix this that run on the Tizen OS.

This really came to a head when I tried to create a stopwatch function for my Active 2 watch using Facer.

For extended battery life I like to keep the display sleep timeout to 15 sec but that makes a stopwatch almost impossible to use. It would be GREAT if there was a Facer command that temporarily overrode the system setting, so stopwatch type functions could stay awake and show the second hand for at least a 1 minute period. One could easily tap on the screen occasionally to extent that minute but that approach gets pretty crazy with a 15 second sleep timeout !!!

This is definitely a Tizen thing. There is the StayLit app for Wear OS that overrides the AOD screen dim time. I can’t find anything like that for Tizen.

Facer Staff-

A thought of a simple way to implement the “stay awake” result (assuming it is possible in Tizen).

If the #SWISRUNNING# state is true then keep the watch display “awake” for 30 more seconds. This keeps the screen alive while the stopwatch is being used and then keeps the screen on for another 30 seconds at the end so the screen contents can be read before the display goes dark again.

If there is no direct Tizen OS mechanism for “keep awake” then can the Display>Screen Timeout parameter be set to "1 minute (for a cushion) and then is there a “screen tapped” variable than can be repeatedly set true to keep the display alive? When #SWISRUNNING# goes FALSE then wait 30 seconds and reset the Display>Screen Timeout back to the User Setting.
[:-)>

When you use the auto wakeup gesture, like turning your wrist, it will only stay on for 5 seconds then dim. If you use a manual wakeup gesture like press a button or turn the dial, it will then stay on for the selected time. That’s the way it is, no further adjustments available.

1 Like

I have always wondered why sometimes my Active 2 and Gear S3 Frontier would sometimes stay on longer and other times not. Your explanation makes perfect sense why.

I can confirm what @bobkautz1 has explained

1 Like

I want to amend my comment here. This Stop Watch issue is a real show stopper. Come on Facer guys… is it really that hard to fix? I modify my suggestion to be whenever the #SWISRUNNING# state is true then keep the watch display “awake” for 10 minutes!!!. As soon as the RUNNING state is false then revert the display timeout to the user setting again. This should allow stop-watch faces to work reasonably yet quickly restores the desired user setting when the timer is stopped to save battery life.

The stopwatch is a very useful Facer function, but it is a DUD right now if the face turns off every 15 seconds (or whatever). Come on guys… get with the program!