Dim mode to dark to use

I have a Galaxy watch Active 2. the dim mode on any of the watch faces I can get though the app is fine. however when I use a analog watch face from facer the dim mode is much to dark to be readable. there are some that I can read but I would like to be able to make my own readable. this wouldn’t be that big of a deal if the watch app didn’t have to load for 4-5 seconds sometimes when I go to check the time coming from a lock screen. I really like the ability to make my own watch face and to have access to thousands of watch faces. However, I do not even want to use any facer watch faces simply because when I go to glance at my watch I want to be able to actually see the time. what is even the point in having a nice watch face if it takes longer for my watch to show me the time than for me to pull my phone out of my pocket? Id just use my phone to check the time at this point. please if anyone knows a fix it would be much appreciated.

I don’t have a Galaxy watch so I don’t know if your watch settings give you options for Dim Mode brightness. Does this happen on all watch faces or just on your creations? If it is yours, in Creator try duplicating your watch face layers on new layers for Dim Mode. By doing that you can adjust the opacity of each layer to your liking. In Active Mode turn off Dim Mode visibility.
Many people prefer dark Dim Mode or disable it altogether in order to conserve battery charge.

Seems weird to me that there should be a delay of 4-5 seconds to wake the watch up. Is this just with Facer? If so, I would try uninstalling it, restarting, and re-installing.

I’ve experienced it with others but not all. It could be other creators having the same problem I do. I do have the opacity 100% in dim mode but still much much darker than non facer watch faces. But I also can’t seem to figure out how to turn off active mode. Is that through the watch or the website? BTW is there an app to be able to make and edit watch faces through mobile? The website is basiclly anti mobile friendly and I have a crappy computer.

In my watch (not Galaxy) in Settings > Display there is an option to adjust Always On or Disable. My Always On is set to Disable/Off in order to conserve battery. In other words, Active turns off after a specified time so all I have is a completely black face until I tap to wake it up. Did you check your Display settings to see if your watch has similar adjustments?
As far as your app questions, I doubt editing can be done on mobile, but maybe someone else can tell you for sure. I create all my work using a graphics app with elements exported to Facer via the computer. If your computer is old and you don’t want to spend lot, perhaps you can find one at one of the OEM outlets.
Both Dell and Lenovo have them: Discounted & Clearance Laptops | Lenovo US Outlet Store and Refurbished & Overstock Laptops, Desktops, Monitors: Dell Outlet | Dell USA

I only have experience with one watch (the one I own), but it seems to me that any settings related to dim and active modes are on the watch itself, and they differ a little in their implementation depending on the watch. On mine, I typically have it set to “always on”. For this, it shows active mode for a specified time period (can be 5, 10 or 15 seconds), and then goes to dim mode (I can re-activate active mode by tapping the face (I have wrist movement to wake turned off). I usually use faces that have a dim mode optimized for OLED screens, so that the battery use is lower and the face is happy to work in dim mode all the time. For example, I have one of my own - Syncro 3 () that is designed especially for use with dim mode. I can have this set to “always on” for a long day, and still end up with 50% battery at the end of it. And that’s on a watch with terrible battery life. If this is dark on your watch, I’d say there’s either something wrong with your watch, or the settings. But if its only in Facer, I would also try reinstalling the app.