Disable Daily Style notification

Every morning at 6:00AM, I receive a notification that says “Your Daily Style is ready. See what new faces you got today!” Every morning I have to dismiss it or open the Facer selection and select the face I am already using.

I want to be rid of this notification completely but can’t find any setting that disables it. I don’t use, need, or want a daily style; I use Facer to create my own watch face that looks exactly how I want it to, and I don’t change it. The only links I can find online about disabling this have no actual resolution. If anyone knows how to get rid of this notification, it would be much appreciated if you could share this information with me.

I’m on a Fossil Q Explorist HR running Wear OS 2.17 (Home App says, using Facer 5.1.47_102391.phone and 5.1.47_1023922.watch.

I am “assuming” you are using an Android phone. In your Facer phone app go to Facer Settings>Push Notification Settings. In that area turn off all the notifications that you don’t want to receive. The ONLY things I have turned on are “Followers” “Likes” and “Comments” everything else is off.


You are correct, Sorry, I thought I had stated that I was using Android but apparently I left it out. I will try this, thank you.

This didn’t work. I still get the notification on my watch every morning.

Oh, I thought you meant they were on your phone. I was getting a “Daily Mix” message on my TicWatch E for about a week and then one day it quit. I don’t know why it started or stopped. The only thing I can figure out is it happed after an update. I kept dismissing them and after a week I just started ignoring them and they quit a couple days after that.

I finally was able to long-press on the notification and turn off all notifications on the watch, and now they are gone. I was trying to find those options through the settings menu, but was unable. I will chalk this one up to WearOS not being as user-friendly as I would like :slight_smile: