DISDAYTIME not working on watch

I’m using

$#DISDAYTIME#==true? 100 : 0 $

$#DISDAYTIME#==false? 100 : 0 $

to control opacity on images. Sunny background for daytime and night sky background for after sunset. It works properly on the site but doesn’t work on the watch. It never changes the image. I’m also using the same method to change colors of date/time elements by duplicating the elements and using the same transparency settings. Am I doing something wrong with the syntax to where it’s not allowing the isdaytime false elements to load because it’s keeping the true elements on the screen? Is it supposed to be 100 : 0? It’s just weird it works on the site but not the watch. Moto 360 2nd gen.

Some help would be awesome.

Ok something i’m doing here is the problem. If I strip out all the “daytime” elements and keep the night time stuff, remove the DISDAYTIME stuff it works fine. I have my night elements and slowly spinning galaxy as the background. If I leave the DISDAYTIME==false stuff in for the image transparency the watch face will not display at all. Does that tag not support false? Should I not be setting true or false and just leaving it as DISDAYTIME without any other options and it will switch by default?

Hey Jay,

After looking at your issue, we’ve found that there are some problems with the #DISDAYTIME# tag. We’re going to look into it, and as soon as we have a fix we will let you know.

Sorry for the inconvenience!

For the time being you can use the new sunset/sunrise tags. You can achieve the same effect with these tags.

Have a nice day!

@Jay Could you try the following statement in your Transparency field of the layer you want to apply the effect to:


Let me know if that works!


Currently waiting on sun to set. Will report back in when it does.

It worked for switching to nighttime! I’ll check it in the am to see if it switched back. It also worked for the date and time I duplicated with different colors and the same transparency tag.