Display random background image on wake issue

Hello everyone,

I’m trying to create a fairly simple watchface that chooses a random image to display as the background each time the watch goes from dim to wake mode. I would also like to fade the image in (transparency from 0 to 100).

This was easy enough to figure out, I just put the expression:
as the transparency for each image (where XX = the total background options, and YY = that specific unique background image number).

The issue I’m having is that, when the watch wakes, it very briefly flickers the previous background that was selected before changing to black and fading the randomly selected image in. Here’s a proof of concept, just toggle back and forth from dim to wake to see the effect I’m describing.

I’ve searched pretty extensively for a solution in the community and only found this thread which showcases an official Facer design that has the same issue.

Does anyone have any idea how to overcome that initial flicker of the previous image?


Well, if Facer Studios published one design with that glitch I asume it’s really not much we can do to solve it.
I tried with a workaround, put a black image over the random ones and fade out that black image on wake and guess what… the same flicker! Unbelievable! I tried with a fixed background image to see if the problem was the black background at start, and the same flickr! Its a tricky one, I’ll keep trying…
Actualization: Its a glitch of transparency just after wake. If you slide the image instead of fade in you will not have any issue.
I put a black image for 1 second after wake using ( $#DWE#>1.0?0:100$ ) over the fade in images and before show this black image it shows a frame of the last image that was fade in. It does not make sense…

@timhicks is this happening on the watch itself as well? or just on the web preview?

1 Like

web, phone app but not in my watch… in my tests… :grin: I should started testing that, sorry! :flushed:

Thanks for the advice and trying to help me out with this. I’ll keep plugging away and see if I can find any other workarounds…

@Facer_Official It’s occurring on my watch as well (Samsung Gear S2).

I assume it’s due to a small lag in choosing a random number and setting the appropriate layers transparencies when the watch wakes… which may be an issue with the device’s processing power and completely out of your control. That being said, I’m happy to share any other info if you want to investigate further.

Cheers! :slight_smile:

Have you tried tweaking the interpAccl so that it doesn’t start at 0 on the off chance it triggers before the wakeRand?

It probably doesn’t help but I’d probably go with a layer on top that fades away to reveal the random image or shrinks to reveal the new image.

Some examples: