#DTIMEFORMAT# always 12?

Newbie here, trying to use #DTIMEFORMAT# but it always returns 12 for me. I wanted to use it in expression but even text layer with this tag shows 12 when face on my watch is in 24h format. Probably doing something wrong?

Hi @janek474,
in the Creator, you have to select the 24h format setting on top right corner:

Thanks @jeberuth that’s useful. I created simple face with with digital time field containing “#Db#:#DmZ# #DTIMEFORMAT#”, it reacts properly when I’m changing as you suggested

not sure how to test it in Showcase mode though…

But when I send it to my watch, tap hold->face settings->Time format - change to 24h->go back – the time indeed will change to 24h but it will still print 12 where #DTIMEFORMAT# tag is.

They not allowing me to attach more pictures since I’m new :slight_smile:

You’re welcome !
On my Fossil, #DTIMEFORMAT# refers to my watch system setting but not to the watchface date format.

Thanks @jeberuth, my is fossil as well. Since facer allows to change 12/24 format and if I’m showing am/pm identifier in separate field I would like to hide it for 24h format since it’s not needed, how should we handle hiding it if the tag isn’t working or is it question to support?

to hide the AM/PM indicator for the 24h format, you have to add the conditional formula as following:


It means, if the time format is 12h then put opacity to 100 (visible) else put the opacity to 0 (invisible).

It works for user format only … don’t know the tag for the watchface time format itself. Any body get this info ?

I would think it’s a bug, since other user preferred tag #UNITSYS# is working properly.

I use the same conditional as @jeberuth does in my faces, BUT I have noticed that my TicWatch E that I use for testing does not recognize the #DTIMEFORMAT# tag. To force it to hide I also have to use either the #UNITSYS# tag or the #WM# tag with a conditional for showing the am/pm only if Fahrenheit temperature is used.

I don’t know if most WearOS watches work with the #DTIMEFORMAT#, but I know for sure TicWatch E doesn’t.