Facer Android 4.5.8 available in Google Play

Hi all!

Facer 4.5.8 is is rolling out to the Google Play store right now and should be available worldwide by the end of the day

The changelog for this release is:

New Help section

  • New: Trending searches!
  • New: Voice search!
  • More dynamic Top Charts section
  • More dynamic “featured designers” section
  • Direct link to sign up to the beta
  • Misc bug fixes and optimizations

We are aware of the following issues which are being actively worked on:

  • Theme, time format, weather syncing issues between Android phones and Samsung watches: the fix for this is still pending approval by Samsung, but we are making progress. New ETA is end of week.
  • Higher than normal battery usage on Android Wear for some users: we are actively investigating this, collecting data on devices to identify the root cause. If you are seeing issues on your side, please contact us at facer-support@little-labs.com and put “Android Wear battery” in the subject line.

Thank you!

The Facer crew


mm end of the week has past…


Hoping for Sunday evening now (i.e. Korea’s Monday morning). Fingers crossed!

New Facer Android 4.5.8 - after update, functions #DWE# is not working on my Asus ZenWatch 3. Animations that exploit functions #DWE# are not working.

Any plans to fix the need to re-sign in every time the app is opened?

1 Like

It’s definitely tracked on our side, but we are having trouble reproducing it in any of our tests. Is it happening to you right now?

Yeah it’s happening right now. I’m using build 4.5.8_8411-(8411)

It can be reproduced by opening the app, signing in, opening recents and clearing facer, and then reopening the app and it will have signed me out.

It’s been happening for a while now. I assumed it was my phone, but after a factory reset, it was still happening.

UPDATE: Tried clearing app data and cache and logged in again. After reopening the app after force close, I’m still logged in! I’ll update this post if I’m logged out in the future.

Facer Gear watch app 4.2.7 is now on my phone
I was not able to update the app on phone as it would generate an “unable to update” error. I was required to uninstall the 4.2.6 phone app and then reinstall the 4.2.7 app. The weather and steps and other complications seem to be working as should be, but need to check an entire days worth to be sure.

1 Like