Facer App uses wide camera (x0.5) when searching for QR code


Hope all of you had a happy new year and holidays!

I have gotten myself a Moto 360 3rd gen, my first smartwatch, and I noticed it has Facer by default.

I switched to an iPhone 11 Pro a year ago (had only Android phones beforehand), as I needed it for development of iOS platform games. Despite some limitations with pairing the iPhone to an android smartwatch, I didn’t mind as it had what I needed anyway.

I noticed some cool looking watch faces on Facer and wanted to try them out. It asks me to scan the QR code and I manage to open the QR code page on the smartwatch.

But the iPhone camera won’t catch the QR code in any way. Tried in a bright room, dark room, well lit room etc…

I decided to try the regular camera just to see if it’s an issue with the watch itself. The camera caught it instantly (though it wasn’t really a link but a mix of characters, so it led to nowhere), but I noticed that it was much more zoomed in than in the facer app. Then I realized it was using the wide x0.5 camera, when I tried scanning the QR code in the regular cam app using this camera, it also didn’t work.
Is there a possible way to change which camera is being used as default in the app?

I have the latest versions of wearOS on both devices, they are paired and work correctly. It’s not a dealbreaker that Facer does not work to be honest, but this is a bug that I can’t fix myself, and I suppose there are more people that could encounter this issue.

Just to make sure… you cannot scan the QR code with standard iPhone camera, you have to scan it with the Facer App.

1 Like

Yes of course, I tried scanning it with the Facer App, I only compared it with the regular camera as I was trying to see if I could detect the QR code in any other way.

This is where I noticed that the default camera in the regular app was different from the one in the Facer app - I couldn’t tap to focus the camera in the Facer app to detect the QR code, and I saw that it looks the same as with the wide camera on the regular camera app.

Oh, OK. Yes, it does not focus well, but I do not seem to have an issue, scanning worked several times.

The only limitation I am aware of with iPhone and Facer, is that you cannot display the battery level of the iPhone on the watch.

This is a screenshot in the Facer App, taken at a reasonable distance from the QR code. It won’t tap to focus on the QR code, so it won’t read from it…

Wanted to send more pictures but since i am a new user I am only allowed one image per post.

It could be something related to my iPhone, though I don’t know what it could be. The camera itself is clean (made sure to clean it a few more times haha), I have a lamp right over my hand just in case the smartwatch isn’t bright enough…

The image above is a test on the regular camera app (done with the regular camera). It seems to identify the QR code immediately…

As long as the latest Facer is installed on both Phone and Watch, and Facer is set as the active Face on the Watch, then the option to scan a QR Code shouldn’t be there, it should be a straight forward sync from the App on the Phone to the Watch :thinking:

Update on this:

While attempting to sync it for the who knows what time, a little icon that opened a gallery popped up (I could have sworn it wasn’t there, it was right under the “Skip for now” button, which I was actually trying to tap haha), it opened the gallery, and I selected one of the regular camera images that was sharp enough to identify the QR code (ironically the one I sent here in this thread), and it just synced!

So it basically synced with an image of the QR code…

1 Like