Facer can not generate QR code in Watch App

I install Facer latest version of Wear OS on my Ticwatch Pro and iPhone 8 Plus.

Once I opened the watch app Facer and tried to tap 4 times to create QR code, it says “Internet connection error cannot generate QR code” .I am sure I connect a normal WiFi but it doesn’t work well.

Any suggestion to solve this problem?


I had the same issue with both my TicWatch-1 and Huawei Watch paired to iPhones after recent upgrades. I rebooted both the watches and both phones and the issue resolved. Hopefully, this will help you as well. If not, you may try uninstalling the Facer companion app on the TicWatch and reinstalling it. That seems to help with a variety of issues that may be encountered.

It doesn’t work for me.

I have reinstall and reboot the watch and app many times and it still shows the error message

Sorry to hear that. If you’re confident that the WiFi is operating correctly then I’m not sure what else to try. Perhaps Facer support can provide some guidance.

Anyone know the url that when generate qr code uses?
Maybe I can add that url to my VPN proxy to force the watch access it by VPN.

Not working.

The watch app seems did not send any connection actions via the wifi that I see the traffic data from my router.

So pity about Facer.

It should be a very good watch app for Ticwatch Pro.

I have a Samsung Gear S3 Frontier Non-LTE and it won’t generate a code for me either. It either brings up the face swap screen with my saved watches, or does nothing at all.

1 Like

I have tried everything. It was working and now stopped and will not generate a qr code. The internet on the watch works have download other apps from the phone.
Is there no fix available?

Sorry meant to say downloaded from the watch itsself

Hi @epiper601!

Sorry about that - can you let me know what type of watch you use?

I have the problem on Ticwatch E (and iPhone XS Max). Other watchface platforms work, and Facer can download the initial recommended faces. Just won’t generate QR code

I have the Fossil Q Venture paired with my iPhone XR and I am having the same problem. My watch is saying it can’t create a QR Code due to the same WiFi error. I have all the most recent versions of apps and updates and everything, so I don’t know why it’s not working.

Hi, I’ve the same problem: I can’t generate the QR code. My smartwatch is a fossil Q and my phone is an iphone with Wear OS by google.

Thanks for your report! This is a known issue and you can follow the latest official updates here: http://community.facer.io/t/ongoing-issue-wearos-iphone-users-qr-code-showing-service-not-available

Can not access to the website you quoted

Sorry, the url changed: [FIXED] WearOS/iPhone users - QR code showing SERVICE_NOT_AVAILABLE

The issue is now fixed by the way. Thanks for your patience!

Still got 3.7.27 version of Wear OS in China App Store. Due to some kind of reason the Wear OS app is an Chinease Sepcial Edition for Chinease users.

Do you hava a ETA for the version 3.11.27 for us Chinease users ?

I have samsung s3,but when i tap 4,times,not things happen,only 3 times tap work that why I can’t get QR code.Can you please help

1 Like

Welcome @vutom . If your Tap 3 times works why do you need a QR Code. What is on the screen when you tap 3 Times. I am presuming S3 is your Phone. Or is it the Watch. I have a Galaxy Active Watch we never see the Bar code on the old Tizen OS.