"Facer connected to Samsung Smartwatch"

My phone shows that the Facer companion app for Samsung Gear S2/S3/sport is running. The problem is, I have a Huawei watch 2. I never got this notification before until the new update today.

Hi!

Do you happen to have the Gear app from Samsung installed on your phone?

Yes. That was it. I didn’t install it, but I guess it was a pre-install on my s8? Uninstalled it and it got rid of that message. Do i need to reinstall anything for my Huawei? Thanks

1 Like

Nothing to install for Huawei - it should work out of the box!

Spoke too soon. The message is back, although Gear app is no longer installed and I restarted

@seuk.kim - ok, we’ll look into it!
Is it preventing you from using Facer on your Huawei?

I have this as well - just started when I opened the Facer app this morning. I also have a Huawei Watch 2 and the notification says Samsung for me. That doesn’t bug me but the fact that I can’t swipe the notification away does. I don’t have a Samsung phone nor do I have the Gear app installed.

If you long press on the notification, I think you can make it go away, but I don’t feel comfortable knowing that I’m just disabling the notification and it’s running in the background. You can also restart the phone and not open the app and it doesnt done on. But not ideal though.

Mine went away today on its own. We’ll see if it comes back.

I’m using a Samsung Galaxy Gear Sport with Facer. I HATE HATE HATE this new persistent notification!!! I did not have any sync issues with Facer (I had manually excluded facer from battery saving on my phone). I imagine the persistent notification is to ‘guarantee’ the app will not be put to sleep?

PLEASE make an option to turn the notification off. If I block it from the Android notification controls, Facer goes crazy with power usage. Instead I’ve stopped using Facer and have left the app ‘force stopped’ until an update comes out to fix this.

I don’t want to lose the investment I’ve made in watch faces. Please fix this issue with the app!!!

Hi all,

Thanks a lot for your feedback regarding the new notification that showed up for some users on Android 8.0+. This notification is forced by the operating system to indicate that a Facer service is sleeping in the background and may be woken up on some events. It has zero impact on battery, but we understand that it’s not ideal and are working on a fix which should be released in the next few days.

Thanks for your patience!

1 Like

Thanks for this status. I also have this issue with the latest beta. I don’t have a Samsung Watch but I do have a Smsung phone. Also fyi that if I slide the notification to the right to get the App Notifications settings and I turn them Off I get an Android warning “Facer app using battery”. (only applicable to the latest Android versions, I am on 8.0.0)