Facer Creator Slow - June 2018

@Facer_Official … Is there a new issue with Creator running extremely slow? My Mac OS Creator is fine, but the web-based Creator has been unusable for a couple of weeks. Not my connection.


We’ll look into it! Is it happening right off the bat, @richpdcomm? or after you do something specific?

Anybody else having issues?

It’s been happening with every session for at least the past week (possibly two, but I didn’t note when it first started.)
The Creator web app launches right away and I can see the project previews.
Selecting a project to edit launches the editor screen with only objects being displayed. The background image is missing, the left-hand object navigation bar is missing and there is no way to proceed until the screen finishes loading. Just now, it took 4.5 minutes to finish loading the project and draw the navigation tools.

After it loads and I click on an object, it takes another 3 to 5 minutes before the object is selected and I can perform any actions.

I usually have to close the browser tab to exit.
Opening the same project in my Mac OS Creator works fine.

This is a US address and my connection is 100mbps+

Thanks for the info! What browser do you use?

Good question. Primarily Firefox, but I just tried with Chrome and it performs much better. Switching back to Firefox, the slowness still exists. Looks like there’s something going on with Firefox. I’m not having any other browser issues except for this one. I’ll switch to Chrome for my Creator work for now.

BTW… I hate to bother you on an unrelated thread. Have you seen my posts regarding iOS Facer and the hope for an account-associated app so that we can purchase faces? Even when I purchase faces from my Android-paired watches, there’s no way to acquire them on my iPhone-paired watches.

Thanks again for a great product.

I’ve noticed some issues today as well. Tested as work during lunch on Chrome. Also at home on Chrome. I have about 15 elements (tick elements) and things are moving very slowly.

@eradicator09 Are you saying it’s slow on Chrome as well as on Firefox?

yes, I am experiencing slowness with Chrome.

Now my Chrome is slowing down as well as Firefox also.

I’m getting lots of this:

Im using Chrome as well and am experiencing really bad lag. (especially tonight) I also have a 1gig connection, running win 8.1

Its gotten to where It wont even save a face in progress prior to publish. If im lucky enough to get to the publish area, once i hit publish, it will act as thought its running through the process, and then times out telling me there was a ERROR saving it and please try again.

As for the last week Ive noticed the lag was worse towards evening 4pm PST on and in the AM most the time there was 0 lag. Hope this helps

Logged on this morning 530 am pst and was able to publish one that i did manage to have saved. However I went to process the second one i had tried working on last night with no success and it still will NOT save prior to the publish. It just sits acting like its in process of saving but never finishes .

What changes were made to this app?

Chrome/Firefox both continue to experience serious lag.
After updating a published face, the “save” took a while but completed.
Then the “update” seemed to hang up after about 10 minutes. Able to exit the page and the published face was no longer listed as an active face. Fortunately, it recorded my save and I was able to open the inactive project where it had an “UPDATE” button instead of “PUBLISH”. Third time was the charm and the update succeeded.

I went back to my Mac-based Creator and things worked much better from there.

Chrome user here… had a page unresponsive earlier… now I’m sitting on the save screen hoping I haven’t lost everything :smiley:

After I posted this morning here, I cannot save anything. All i can do with this program is install faces on my watch. It will not allow me to make anything or update anything. IS there any response here? I too paid for the upgraded version of facer with no ads and such.

Sorry about this guys, we’re investigating - @selia67, is it only hanging on saving a draft, publish a face, or both? Are there other times when there’s sluggishness?

Initially, my problem was loading a project into the Creator editor window. Part of the face would load and then hang up for 3 to 5 minutes while the remainder of the face loaded.
Then working with objects was also slow.

It wasn’t until I was ready to update a published face that I ran into those issues as well with saving/updating.

Thanks for looking into this.

Its on saving and publishing and upgrading… ALL of the above.

HERES a new tip for you…it seems i can reboot and relaunch Facer and sometimes it will allow me to complete one face. But thats only once in awhile…most the time it wont work at all…anything you want me to try to help troubleshoot this?

Hubby and I have alpha/beta tested for MS inhouse gaming core division for over 22 yrs so were used to this .

Over the last 12 hours I have tried 4 times to edit and save changes to a design. I can edit but not save. Creator just hangs – Edge and Pale Moon (basically Firefox) browsers. It was fine yesterday, so something has gone sideways just since then.

It’s definitely during the save process (at least for me)

I’d say about 90% of the time. It got so bad I thought the design was corrupted so I cloned it and that didn’t save.

I ended up creating a whole new watchface from scratch and with the other window open copying all the settings. Saving incrementally after major changes which worked.

But yeah, you click on save or preview/save and it just does the loading animation and nothing else. I didn’t think to check network traffic with WireShark but if the problem continues I’ll provide additional info.