Facer face watch not showing up in LG Urbane W150 watch

Help! My LG Urbane watch is connected to the latest Android Wear app. After downloading the latest Facer app, and going thru the setup process, the Facer watch “face” is not showing up. I’ve reseted the watch, removed and reinstalled Android Wear and Facer. But I still can not select, and therefore, add watch faces to the Urbane watch. BTW I’ve tried it in two phones and I still have the same issue (Phones Galaxy S7, and Alcatel POP 4 Plus)

*LG Urbane Model W150
*Android Wear version
*Facer 3.1.0

What am I missing or not doing correctly? BTW, I used other watch faces apps and they seem to work, except for Facer.

Hi @Kaliman! Thanks for your report!

Starting with Android Wear 2.0, watch apps need to be installed separately on the watch and do not come pre-bundled with the mobile app. One of our onboarding steps in Facer 3.1.0 prompts the user to install the watch app, but maybe that didn’t work for you? Can you confirm you’ve installed the Facer app from the watch store on your watch as well?

Initially, I had Android Wear on the phones. Then I paired/linked android wear with the phone. When I was on android wear I clicked on more faces button then I went to the play store and downloaded the facer app. I installed the faer app and went thru the setup. I got to the “Install Companion App” click on the button and nothing happen. So I proceeded to the next steps. Both Android Wear and Facer were installed from the “android wear” category in google play.

Got it - the fact that “Install Companion App” did nothing is definitely an issue. Can you confirm that your phone and your watch were properly connected at that time?
What you need to do is go to the Google Play store on your watch, search for Facer, and install it there as well. On Android Wear 2.0, Facer will not work unless the app is installed on both your phone and your watch.

Yes, phone and watch were connected. The problem is that my watch doesn’t /can’t go to the google store (no google app store in LG Urbane). I can only go to the google store via phone or computer.

Ah - which release of Android Wear 2.0 are you running? This might get solved once the final version of Wear 2.0 rolls out, which I believe will be before the end of the week.

After several hours of troubleshooting. I finally got it to work. Even with the new android released it took several tries. Here’s what I had to do. Removed Android Wear and Facer from phone. Installed Facer from google play store using computer browser and having the app be sent to my phone. I then launched the app proceeded with the setup. Got to the Install companion up and clicked on the button - nothing happen. When to google play stored installed android wear via sent install to phone. Proceeded to do the whole setup of the Android Wear in my phone. Once this was done, I went to facer and finished the setup. After a couple of minutes, the facer watchface showed up in the watch. NOTE here. This setup is too complicated. It became a trial and error/problem solving setup. This needs to “plug and play.” Other watch faces apps don’t have this issue-- the set up is much easier than facer. I hope this improves otherwise users are going to go crazy.