FACER Community

Facer faces don't show correct time on wake up

To all in this community, it can’t just be me that is irked by the fact that whenever I look at my watch ( Samsung S3 Frontier non-LTE) I have to watch it correct the time, is this true for all watch operating systems please let me know? The very essence of a watch face is that it shows the CORRECT TIME ALL THE TIME. I have moaned about this for sometime and I’m surprised theirs not more discussion/noise regarding this FAIL (please don’t get up in arms over my use of caps). I don’t know why Facer faces don’t work like the embedded Samsung faces but I’m guessing it’s a code/engine issue but I have a suggestion which is only a workaround but might solve the millisecond of disappointment. I’m hoping @Mellin, @Tomas and @jmorga106 (Happy New Year to you all) will get involved in this topic. My suggestion for a fix is as follows and excuse my clumsy pros: Is it possible to set up a layer; black square 320 x 320 using the wake function to shield the face whilst it corrects to current time. Does that make any sense?

It might be the operating system.
I’m using a Sony SWR50 with Android Wear 1.5.0.3508863 and a Vernee Mars Pro with Android 7.0 and I don’t see this problem on my watch.

Just to make sure:

  1. I don’t see it, when I wake up my watch, by rotating it, or by pressing it’s the only button.
  2. I also don’t see this problem, when I restart my whole watch.

I’m sorry, but I don’t think I can be of much help here.

I have the same problem with my designs, i tried a S7, S8, Iphone 8, Iphone X same result, so it’s not the phone or the watch, is something wrong with the app ? i tried many face apps but so far only Facer.io has this.
Do i need to add a event to my second/minute/hour hand ? like a dynamic event or some sort ?

What Watch are you using?

Here we are in 2020 and this problem still exists.

My watch is the Samsung Galaxy 46mm with a face I designed using Facer. As prviously noted, when the watch wakes up it shows the old time for about a half second, then jumps the hands to show the correct/current time.

This is ridiculously amateurish and makes the watch look like it was designed by a grade school person. I know this is a Facer issue because when I switch to a face made with Galaxy Watch Designer the skip does not happen.

So how about it Facer techs - will you man-up and get this issue resolved? Soon?

So another 2 years later and i have the same issue on brand new galaxy watch 4. No problem with samsung watch faces or downloads from play store. Am i missing something or that is how facer works on samsung watches? Checked all the setting thatbi could find.

I’ve seen the delay problem even on Samsung faces on all my watches. I’ve had in the past a Gear S3, Active 2, and now have a Galaxy 1st generation and two Galaxy 4 watches. Plus, a Fossil test watch. The lag I’ve seen on Samsung faces is very short. The lag on Facer is longer on older slower watches, but pretty short on the GW4 watches. The way Facer works, it cannot work in the background like Samsung faces can. It has to update when the watch face becomes active, update then show the time and other readouts. That does take a split second. I’ve been using Facer for 3 years now and I don’t pay any attention to the lag anymore. I just know it’s going to take a half second to catch up and I go on with life. For what it’s worth I just checked the time on my Galaxy watch 1st gen using the Samsung dashboard face and seen the minutes update in a blur just before showing the correct time.