Facer is not showing up on Sony SWR50

About 2-3 weeks ago I had to reset my phone to factory settings, deleting all of the apps and data, including Facer that was running on my smartwatch.

After setting up everything full again (including connecting my smartwatch to my phone), I installed and set up the Facer app from play store and waited for the Facer to show between available faces on my watch (when I long pressed the original face on it).

I’ve been waiting for it for… those 3 weeks now. It does not show on my watch as an available alternative face when I long press it. It does not show up among the available face in the Android Wear / Wear OS app on my smartwatch.

I used the Advanced Settings / Resync Apps option in my phones Android Wear / Wear OS app many times during this week - did not help.

I tried to delete paring between my smartwatch and my phone and reconnect it again - did not work.

I tried to deinstall and reinstall the Facer app on my phone - did not work.

Resetting my phone to factory setting - it literally started the whole problem.

Restarting both my phone and watch in different orders did not work too.

My watch is still among the supported watches both on the main Facer site (https://www.facer.io/) and in the android Facer app itself, so I have no idea why it does not work after reinstalling everything.

I’m using the following setup:
-Sony smartwatch 3 SWR50: Android Wear 1.5.0.3508863, Google services 8.7.01 (2590918-534), Android system version 6.0.1
-Vernee Mars Pro: Android 7.0
-Wear OS app: version 2.25.0.252388616.gms
-Facer app: version: 5.1.14_101131-(101131)

I include a screenshot of my phone’s Android Wear/Wear OS app showing available faces and an area where the Facer should be visible but isn’t.

Sorry you have probably done this but I could not see it in the description …

Is there a Facer Companion App for your watch? Did you re-install it?

Have you gone into the Play Store to restore all of your purchased faces?

@Mellin! you’re still alive? :slight_smile: That’s great!
I forwarded your post to our test team who has been investigating similar reports.

1 Like

I have the same problem, with the same watch.
Tried resync the companion app but nothing come out on my watch.
Hope this is solved soon!

I just installed mine to my don’t smartwatch 3 and I can’t seem to find the companion app. Is not working

I am having the same problem – no Facer watchface listed among the available watchfaces. When I run the Facer app on my phone, is shows under settings it knows my watch is the Sony Smartwatch 3, and has an option to re-install the Companion App, however that option apparently requires that I select Facer as my active watchface to begin with, which is the problem I am trying to solve.

I tried all the things Merlin tried without success.

Hi there!

We looked into this issue recently, and identified a couple possible issues here:

Can you give that a try and see if it helps?

Edit: if this doesn’t work or you have any questions, please email us at facer-support@little-labs.com. We’re actively working to make the install process easier for WearOS 1.x users.