Facer not syncing w/ samsung galaxy 8 plus to samsung gear s2

Please please help me! I have been trying everything the last 2 days to sync facer with my verizon samsung galaxy 8 plus to my samsung gear s2 watch. I have googled everything. Tried ALL the suggestion and nothing! The galaxy app store doesnt show that the facer companion app for the samsung gear s2 even exists anymore! I live in the USA. Is there an issue with this? My husband has a Google phone and had no issues syncing the app to his samsung s2. Is it my phone? Is it a galaxy issue. Please I am so frustrated I really really want to use this app. What can i do to fix it??

I looked the app up yesterday and it was there.?..maybe pop into verizon and make them help you find it?

1 Like

Can you tell me what the name is you found it under? Also was this in the galaxy samsung app store? I am able to download the the facer app from Google play but then it directs me to to the galaxy app store to purchase the facer companion app for the samsung gear s2 then I get an error that the app no longer exists :pensive: It is so frustrating.

2d
hmm Try this. Open samsung gear app on phone…make sure you under Settings at the top on the samsung gear app…and not the INFO tab.
Scroll down to Samsung galaxy apps (3rd one from bottom) and open it. At top search for Facer…Facer companion will pop up on the list first, and i think yours is the second one that says Facer Companion for Gear S2…tap that one and hit the Play arrow on the right of it and install it …

1 Like

Thank you for trying to help. Unfortunately even trying what you mentioned it isnt showing the app available on my phone :pensive: I even just call the samsung galaxy app store customer service and they were no help and said that only applications that are compatible with my phone will show up in the store. I have a galaxy s8 plus phone. I am assuming you must have a different phone? I am so frustrated. Is there anyway to get help from facer themselves?

They should help as soon as they can…maybe someone else here can help

1 Like

Sounds good thank you again.

Ok when you follow the steps above I posted…BEFORE you type Facer in the search area MAKE sure your on the GEAR tab at the top…if you are on the phone tab it will be blank

Unfortunately this is what I have done and it still doesnt show up :pensive:

Has anyone worked out how to get Facer companion yet?

what is verizon?

Verizon is the cell phone company/carrier. The original poster mentioned their carrier was Verizon

How do I contact Facer experts on this issue with Facer companion not being in Galaxy apps ?

I have a Samsung Galaxy A8 (2018), and Gear Sport(s).

Not having any issues with connectivity in Australia. I did a quick search for “facer” in ‘Galaxy Apps’, and the app showed as both the first and second items found. I re-installed it last week, on one of my watches.


I had a look at Samsung US website, for Galaxy Apps / Store. It is next to useless …

There have been recent updates to ‘Galaxy Apps’ and ‘Samsung Gear’ on my phone, and these completely changed the way you install ‘Facer’ to the Gear device …

Can you check for updates for these apps. and check their connectivity to the ‘Gear S2’. I am very familiar with the ‘S2’, as I had one until I ‘upgraded’ to the ‘Sport’.

You first might want to say where you live and who your cell phone carrier is. Sometimes the carrier will block or remove things…for example a few years ago Samsung blocked the ability to transfer apps to the SD card. …now they allow it after millions of complaints lol AND as far as getting ahold of Facer …this is the only way. All you can do is hope they respond

Have Zeblaze Thor 4 running Android 7. I live in Australia Melbourne Carrier Vodofone. Have Samsung Galaxy 9 plus. No problem finding Facer in Google play. Finding Facer companion in Galaxy apps not there. No problem pairing phone to watch but Facer can not pair to watch.

I have Samsung Galaxy A8 (2018) on Vodafone AU, and have no issues. Running two Samsung Gear Sports with Facer.


Can you try searching for ‘Facer’ on watch itself, under Galaxy Apps? (as crazy as that sounds)