Facer not working on Samsung Galaxy Watch4

Help needed Galaxy Watch4 Facer keeps crashing since update. I paid for yearly subscription but now I’m unable to use Facer on my Watch4 :weary:

1 Like

Welcome to Facer! Have you tried a factory reset on the watch?
(Settings > general > reset)

I’ve had to do that a few times when I ran into similar situations on both my Samsung GW1 and GW4, and starting from scratch fixed them.


I also have a Galaxy4 … And from Time to time i need to reinstall Facer . As stated above , try reset the Watch…

Hi there! Can you send a support request on help.facercreator.io ? On the top right you will see an option to send a ticket.

@len4444 how did you make out, did anything help your issue?

Still got same problem after resetting my Watch4 the third time. I’ve got fed up having to keep putting Facer back on my watch. Facer works for a couple of hours then for some unknown reason It disappears and I have to install it back on again :cry:

That is really odd. I have both the GW4 “Active” and the GW4 Classic and have had no problems with either like you are describing. Both of my watches have the latest GW 4 updates which might be part of your issue if yours isn’t up to date. The last update didn’t automatically update itself or even notify me. I went to “Watch Settings” > Software and found that there was a newer version.

That is indeed really odd. At this point I’d say contact Facer support directly, as suggested earlier. Hopefully they can help resolve it.

1 Like

It seems I’m having a similar problem.

I’ve had my GW 4 classic 46mm for almost a month now, but just yesterday Facer faces were no longer showing up, only the samsung faces.

When I started the Facer app in the watch, it shows the screen with the Facer logo at the top, then “100k faces for you” and other stuff. If I swipe down to “recently used” it shows my recent faces in there. I choose one, it says it’s assembling the face just like always.

But then I get a screen that says “One last step! Select Facer on the next screen to set it as your watch face” and it gives a visual of what that will look like, with a “continue” button under that. I hit continue, and no additional screen ever comes up. It just goes to the samsung watch face that was on before this.

I uninstalled and reinstalled Facer on the watch. It eventually worked. But then, again, overnight last night, it reverted to the Samsung faces, and back to square one.

I haven’t tried a factory reset, but even if I do, what’s to prevent this from happening again in another month?

I tried going to help.facercreator.io to submit a support request, but it doesn’t recognize my login.

Huh, weird. I just opened my Galaxy Wear app on my phone to look for some better watch faces. It showed Facer as a recent face, so I tapped that, and it loaded the facer watch face no problem.

I did check for watch updates, and there were none, according to the phone Wear app.

Restarting your watch will usually fix odd problems like this. I head that off by switching to a Samsung face and then shutting off my watch before charging it. I have both the GW 4 “Active” and GW 4 Classic and am having no issues other than the AOD on my “Active” version won’t allow me to allow Facer to run in the background for some reason. I’m also on the latest app verson 6.0.1.

1 Like

Fix, for how long? I know, it’s the nature of these sorts of things. Thanks for the reply, though.

We’ll see how long it “sticks” after my selecting Facer in the Wear app on my phone. Seems to only happen overnight while in Do Not Disturb and Power Save modes. Two nights in a row so far. Will see how it goes tonight.

p.s. You’re awfully social for an anti-social guy! :sunglasses:


I wear my “Active” GW 4 every night to track my blood oxygen and sleep. That includes my watch being in Do Not Disturb all night, but I never use power save mode. I’ve seen where @rob.fisk had issues with his Fossil gen 6 and power save mode, but I think it might be just on Fossils that has the issue he had. On the other hand, you might try using the normal power setting and see if the issue repeats itself.

I’m gonna wait and see what happens. If it’s good for another month, and I can fix it by selecting facer in the Wear app, then it’s fine.

1 Like

I still have same problem and I paid for yearly subscription too. But its worthless if it don’t work :cry:

Well, it’s been a couple nights in a row, and nothing abnormal happening. So I guess it’s “fixed” for me.

@len4444 & @Steel_Rat

I don’t know if either of you do this, but I always turn my watches off when I charge them. That way they are not running long periods of time without being restarted. I’ve found that watches, especially WearOS ones, are like old Windows computers and need restarted often to stay running smoothly. I even go so far as to change to a Samsung face to make sure that Facer is cleared from the memory just in case WearOS keeps it “alive” in a memory image.


I never did that with my Gear S3, and had no real issues. But, it seems the newer Samsung stuff (My S20 phone and this Watch 4 Classic) aren’t as software stable as Samsung used to be.

I’ve been a Samsung guy since the original Galaxy S. Had the S, S3, S5, S7, S8 and now the S20 FE. Everything including the S8 were solid, the S20, not so much.

1 Like

I have the same watch and the same problem, I found that if I go to the Samsung Wearable app, with the watch connected, select watch faces, scroll down to the downloaded header, under that there should be the Facer watch screen, press on that, this will load the Facer watch face in your selectable faces and then you are good to go.