Facer Phone App hangs after S8 Oreo Update

My Samsung S8 got ‘upgraded’ to Oreo last night. The Facer phone app now just sort of ‘hangs.’ I’ll open the app, and get an Android message that “Facer is not responding. Wait? Close App?” This appears within only seconds of opening the app and I’ll just click Wait every time. This often causes literally every Facer face on the app to just show the generic “F” Facer logo. This holds true for all faces in my watchbox, both purchased and free, as well as any faces I try to browse. The pic of the face just doesn’t load even if I click the face to view it. After a while, faces will load, though.

Syncing does work fine once I can get the phone app to actually display faces. Again, I’m not actually doing anything to get the faces to display and work. After a while the faces just start appearing/working again. The “Facer not responding” message still appears every time though.

I’ve already tried a full uninstall/reinstall of the Facer app on my phone. It didn’t fix the issue. I did not try reinstalling the companion app for my Gear S3. No problems on the watch.

Hi @eruption77!

Thanks a lot for your report! We definitely want to investigate that with you and fix it asap.

Were you able to identify a pattern for when the phone app does load vs. not? Have you tried uninstalling and re-installing to see if it helps?

@Facer_Official the hanging issue where just the Facer F shows in place of all watch faces is really sporadic. I’ve not had the problem today at all, but it was happening a lot yesterday.

In contrast, the Android “Facer is not responding…” message is fairly consistent. Happens almost every time I open the phone app. Clicking ‘Wait’ allows me to still use the phone app fine, though.

I’ve also noticed the watch faces are really hit more miss when it comes to showing the phone battery level for faces that show the phone battery. Sometimes it never updates, sometimes it works fine. I often have to actually re-sync the face to refresh the battery. What’s weird though, is when the phone battery isn’t updating, just for testing, I’ve tried changing the color theme of a face through the phone app, and that works fine. Point is, this tells me the Facer phone app IS ‘talking’ to the Facer companion app on the watch.

Yes, I’ve tried a full uninstall/reinstall of the Facer phone app but the problems still remain. This was never an issue while on Android Nougat. It’s only since Oreo was pushed this became a problem. Overall, my phone is fine too. There are no other problems with any other apps on my phone acting up so it seems isolated to just the Facer app.