Faces wont sync with Fossil watch on iPhone xsMax

Hello. I have a Fossil Q Venture HR running Wear OS 2.9 and have the latest Facer app running on it. I am using an Iphone XS Max on IOS 13.1.3.
The Facer website acknowledges I am wearing whatever face I have chosen, and it will say it was "sent’ to my phone, but on my watch,the face doesn’t show up it just stays on the normal plain, blue Facer face. It will not change, unless I use one of the default Facer faces that is already on the watch.
So far, I have turned bluetooth on/off both my phone/watch, turned both devices off/on, deactivated/reactivated my Facer account to re/sync it. Nothing has worked. Every other face I have tried, like the normal stock faces that come with the watch works, and another 3rd party face app works, but I really want to use Facer. Does anyone have any idea what may be wrong?


I do not have an IPhone so I can’t help with that part, the only thing I can think of is to check that you have notifications turned on in the Facer App. It needs to be on in order to sent faces from the web app.

Thanks for replying. Where do I check this?

In the facer App,

  • go the home tab ( tap on the * Home icon, bottom left of screen )
  • tap on the icon at the top left of the screen - it looks like a set of parallel lines
  • go down to the settings icon, looks like a gear wheel
  • This should have brought up the Facer Settings screen
  • check if there is a tick mark next to “Receive Push Notifications”. If there is not, then tap on the small box to place a tick mark.

I hope that helps.


Hmm, must be like that on an Android phone, cause it looks nothing like that on the App for the Iphone. There’s not even a Home tab and the settings only has FAQ & Troubleshooting, Reconnecting Watch and Device Type.

1 Like

Ok, sorry - that was my only idea.

Hopefully @Facer_Official or someone else will chime in with ideas.

Otherwise, have you sent an email to support at


Yes, I’m still waiting to hear back. What’s weird is, I connected the watch to an old, disconnected LG Phoenix phone and it worked perfectly. So, I know it’s not the watch. I don’t understand why it wont work with the iPhone. It’s gotta be something with the app and the website’s ability to sync with Apple.

1 Like

There are various old threads that talk about IPhones and thing that people have tried that seemed to work. If you have not already done so, you could do a search of the old threads to see if they can help.

I did, that’s what I’ve been doing since Sunday and the ones I did find most of them were for the Samsung/Galaxy issues, and the others either didn’t get an answer (one had the exact problem as me, but never got an answer), or what they tried didn’t work for me. It’s incredibly frustrating. I’ve been at this since Sunday. Are you aware about the Feed thing the FAQ’s was talking about? It says that needs to be turned on, but as I understand it, there is no more Google Feed.

Sorry no, no information about “Feed”. I hope you find an answer soon.

@Facer_Official, is this a known current issue that is being worked on?

I found my similar problem solved today automatically…

1 Like

I have been having the same problems but I have gen 5 Carly. Any help to fix would be great

I have the exact same problem now, with my Fossil Q Venture HR (4th Gen.) and my iphone 8. Facer used to work fine on my phone/watch, but that was before an app update this past Summer. Now I can’t get new faces to sync to my watch. I’ve tried everything you have, to try and fix this; however, nothing has helped. I’ve come to the conclusion that this is an issue that @Facer_Official will need to address with the app. It’s not the watch or the phone that is the problem, as this pairing used to work fine.

I came across a helpful post on this community, which I’ve pasted below. I tried the suggestion (of turning the Bluetooth OFF on the watch) and was able to send Facer watch faces once again to my watch. After I transferred my favorite Facer watch faces back over to my device, I turned Bluetooth back ON on my watch. It’s a work-around that worked for me! I hope it helps.

I have the same issue with my iphone. When i set up the watch the first tine everything worked as it should. Recently the watch stopped syncing with the phone. I rest the watch factory settings. Now facer will not sync with the watch. The watch syncs with the iphone just fine.
Any suggestions