FACER Community

Fahrenheit temp wrong on Samsung S3 Frontier (Celsius correct)

I created my own face design for my watch years ago. It has been working fine all this time. Yesterday the temperature was wrong. It was showing 150 degrees Fahrenheit. Today I logged on to the Facer web site and made a change to the face and pushed it to the phone. The temp is still wrong. From my phone, I changed the temperature to display in Celsius. It is correct when displaying C. I went back to F, and it is wrong again. All of this seems to be on the watch. The Facer app on my phone shows the correct temp for both C and F when I change it. It’s just when I push it to the watch, it is showing F 80 degrees too high. I have restarted both the watch and the phone with no change. Any help would be appreciated.

I’m wearing one of my faces right now and it is reading the Fahrenheit temperature correctly. Are you using just the standard #WCT# tag? It might end up being your local weather station that uploads its data to OpenWeather might be the problem or something between them OpenWeather Facer and your watch.

Thanks for the reply. I opened the OpenWeather web site, and it is showing the correct information. When I flip back and forth from C to F in the Facer app on my phone before sending to watch, the “face” in the app changes and shows the correct temp. When I send to watch, it is 80 degrees high for F. The tag in the designer is “#WCT#°#WM#”.

1 Like

You might consider invoking @Facer_Official for help. You can contact Facer at: https://help.facer.io/hc/en-us/requests/new or email them at: facer-support@little-labs.com

1 Like

I will contact Facer. Thanks for the info. I just uninstalled Facer and its companion app and reinstalled. The temperature is still off…now by 88 degrees. It says it 158F when it is 70F (according to the OpenWeather web site). However, I did change to some free face from the app that shows temperature, and it showed it correctly for F. Now I’m even more confused. I’m using the correct tags in the design (actually I chose the style after adding the temp from the designer, so I didn’t type anything by hand). This face has worked for years, and I have not changed it at all in that time. It just started showing the incorrect temperature yesterday. I may create a new face from scratch and see what happens. Thanks again for taking the time to read and reply. I appreciate it.

Making a new test face with temperature and a digital time only and syncing it should answer your question if it’s you or Facer. If by some odd chance it does fix it, then I would duplicate the face you are having issues with and sync the copy of that face and see what happens. It might be something else in the face that is disrupting the temperature output. Or just the fact that Facer has changed how their system works and it is no longer compatible with an older watchface. I had that issue before and had to totally update about 10 older analog watchfaces so they would start telling time again.

If your problem face is published, post the link here and I can test it on both Tizen and WearOS to see if I have that issue.

I recreated (did not duplicate) my original with some changes to color and maybe font size. The result was the same. I also just did a new, selected the analog with the hour, minute, and second hand. I added the temperature only. I saved it and sent it to my watch. The temperature is still off, even on the brand new one with time and temp only. I think I published my original successfully. Here is the link to it: AUGrad98 - BlackWithUTC - watch face for Apple Watch, Samsung Gear S3, Huawei Watch, and more - Facer

I am in the Eastern U.S. time zone and it’s 4:01 pm right now. Your watchface on my Fossil Carlyle is showing 77°F and my personal watchface on my GW 1st gen is also showing 77°F. So I can say it is NOT your watchface that is doing it. It has to be your location. Unless other people’s watchfaces are showing the correct temperature on your watch. Here’s a test, sync MAG 2097 which is the watchface I am using on my GW 1 and see if it shows the correct temperature for you.

I installed that face, and it is off too. Earlier I said other faces were correct. I realize that I changed the face using the Samsung Wear app, so I was using a face from Samsung and not Facer. It shows correctly. Any face from the Facer app is off. The strange thing is that I can switch to Celsius on the face(s), and it shows the correct Celsius temperature. I’m in Alabama and Central Time Zone. It’s showing 163F on my Samsung S3 Frontier. Switching to Celsius shows 23C. In the phone Facer app, when I change the unit system, it does show 72F on the face in the app, but on the watch it is showing 163F.

I do appreciate your time giving me a little help with this. Maybe it’s just a glitch that will self-correct in time.

That is really odd. I would almost be willing to bet that the weather reporting station near you where OpenWeather is pulling its data from is having an issue or OpenWeather itself is having the issue. If I were you, I would email @Facer_Official and at least report it so they at least have documentation of it.

I sent a message to facer official. One thing I have figured out: if I convert what shows as F to C, it converts to the actual Fahrenheit temperature. It’s showing 151F right now. If I convert 151F to C, I get 66.11111C. If I look at open weather, the temperature really is 66F. I wonder if a change was made to the facer companion for Samsung Gear S3 Frontier? It’s like it’s pulling the F temp, thinks it’s C, and then converts that to F.

I’m using my Galaxy Watch 1st gen and I’m on Facer phone app version 6.0.13 and watch app version 5.2.0.21. My Facer watchface says it’s 70° and OpenWeather on my phone says it’s 68°. Accuweather says 71° and my S10e cellphone weather from the Weather Channel says it’s 70°. It’s beginning to sound like there is some corrupted data in your watch app for some reason.

I’m not sure what happened. I compared versions, and I noticed my app was installed from the Samsung Store instead of the play store. I uninstalled again, installed from Google Play store, and then forced an update of the companion app from the Samsung store. Now Fahrenheit is correct again! I have no idea how it got messed up. I don’t have Samsung Store auto updating apps. Whatever happened, thank you for spending time looking at things. I appreciate it. I had already uninstalled and reinstalled, but if you hadn’t posted your version numbers, I wouldn’t have tried it again, nor would I have noticed that I’d somehow gotten the Samsung Store version.

1 Like

That is good news that you got it fixed. Either the Samsung Store version is corrupted, or it got corrupted while it was going through the internet to be installed. Either way it’s working now, so go celebrate!