Fossil Gen 6 Heart Rate Monitor Not Working

Made a watch face in the facerr studio for my Gen 6, and everything works perfectly (including steps as far as I can tell), but the Heart Rate monitor does not work. The Wellness app tracks my heart rate just fine, but the heart rate monitor in my watch face does not. And yes, I checked the HR monitor and the value is set to #ZHR#.

I’m using the WearOS app on an iPhone 13 if that helps.

1 Like

Welcome @feraligatorade1999 So we need someone with an Apple phone to help here .
When you install Facer on your watch you should be asked to confirm permissions for sensors you should accept all on contiuous . Try reinstalling the Companion app on your watch . You will have to get your Faces back but it should fix the permissions .

1 Like

The heartrate on my Facer face for my Galaxy 6 Classic hasn’t worked for months. I think the Facer watch app is simply broken. Heartrate works fine in the watch’s Running app and manual measurements, but on my watch face is seems to show only random values - and sometimes zero.

1 Like

It is worth trying this . Stroke and Glow cause issues on faces other than Tizen . Put your HR count in Brackets .

That’s very strange Russell, but I’ll give it a try. Thanks.

Well - it might have worked.

I saved the update and reloaded my face. Now the heartrate agrees with a manual measurement. So that is encouraging. I’ll check again after I go running; that gets my rate up above 100. And yes, I should have checked what it said before the change. But I didn’t.

Thanks again.

PS: I still haven’t ventured up to Venice to see if there are any live people working at Little Labs. LA traffic has gotten simply unbearable.

1 Like

I would love to see a real picture of the Office . I am sure they would welcome a Maker . I guess they are Quite cool but just took a Big Bite . If you ever go for a run round there switch your Strava on and post the Map .

Well, it appears that Russel’s fix does not work for me.

After a 32min. run the watch’s Running app said my heartrate was 113. When I switched to my standard face (the one Russell showed above) it showed 110 and a few minutes later 101. I measured manually again and the reading was 93. My face still showed 101.

Several minutes later the manual measurement showed 83. Now, about 15 minutes later, my heartrate says 69, but my face still shows 101.

I’m considering calling Little Labs and seeing if they have anyone there who will talk to an end user face - face (pun intended). If I go in late morning the traffic might not be too terrible.

1 Like

So today I woke up and took my watch off of the charger, and the heart rate is now stuck at 78 instead of 0. Putting the HR function in parentheses made it change once to 79, but I think that might have just been the face loading again.

1 Like

I think we (meaning me) suffered from a miscommunication about the suggestion “Put your HR count in Brackets”. In the US these are brackets: [ ]. These are braces: {}. And these are parentheses: (). I tried brackets (the square ones) and braces, but those just added those characters to the watch face. So I changed the Effect parameter to “none” and left it at that.

This time I went back and used parentheses around the #ZHR# as Russell suggested. But that didn’t fix the problem either. So the situation, at least for me, is still unresolved.

1 Like

Have a good trip to Venice .
If the HR is set to " Continuous " it is not actually contiuous . The HR I use on my watch is not on all the time . I have it on a Data back that is called with a Var Tap Pad . It updates within 2 or 3 seconds to be the same as the Samsung Health reading . To be honest if I had a Heart Problem I would not rely on Samsung / Facer Sensors . That is the Reason they can not get FDA Clearance .

Sorry about Laziness . I will trytremember the Different names . During your instalation of the Facer Companion App on your watch did you confirm Contionuos Sensor Monitoring ?
Have you set Contiuous on the Galaxy Wearable App on your Phone or on your Watch .

No. And no.

I’ve installed (and re-installed) the Facer Companion a number of times and never saw any option to specify Continuous Sensor Monitoring - or any options at all actually. Is there some secret trick to get a display of whatever options there are?

I’ve not installed Samsun Health either. I looked at it once and saw that it all sorts of personal data on some Samsung server somewhere on earth. I didn’t like them (whoever they are) retaining all that data about me, and it also seemed to me that gathering all that data and transmitting it would suck up gobs of battery on both my watch and phone.

Plus I never did that with my original Galaxy Watch Classic and it worked fine.

Truth is I’d like to retain my heartrate data for more than a week because I’ve been experimenting with different running speeds as a means of avoiding heartrate frequency peaks. I’ve seen spikes of 15 - 20 beats/sec for short periods, and I’m just now learning how to prevent those.

So I did install Samsung Health again, but when I try to sign on it says “Server error occurred. Try again later. (0x2F#0)”

I’ll try again later today.

1 Like

Ah Right . not a Simple issue then .I think I am right in saying your previous watch was a Tizen . Different story . I use Samsung Health because I have a Samsung watch and Phone . But really if you are that serious about logging your HR sounds to me like you need an App . It is possible to show data from an app from the Google store on your watch . There are severe restriction on what is displayed . I just run them Hidden and when you tap the Pad Area it pops up Full screen . I am not a pro Maker at the moment . I can not remember if you are . One of the Pro Makers can make you something . Let us see where you want to go . We could strike up a DM .

Let’s not mix horses with cows…

Getting historical heartrate data from the Running watch app is a secondary issue (cow). My primary issue is getting the standard watchface heartrate component to work (horse.)

It seems like all the options to get that one (horse) working have failed, which suggests to me there is some internal firmware mismatch between Facer Companion and Wear OS. Needless to say it’s impossible for an end user (me, not a horse) to know if this is true, and if it is, what to do about it.

Years ago I posted a question on the Samsung Galaxy Watch message board about if it was possible to export the heartrate data from my watch to my phone. The answer, from the forum moderator, was no, because at that time there was no software that exported anything, and even if there was the data was in an encrypted/compressed/proprietary format. This was when I had the prior/original Tizen based Galaxy watch. I’m sure Watch OS is different, but probably just as mysterious.

Right now my watch sys my heartrate is 62, but measuring it results in 54. To quote Ralph Cramden: “What a revolting development this is.”

1 Like

Sadly If I cannot test something I can not help . All I can do has to be Practical . Sorry to add Confusion . It seems to me that it is a question for Little Labs or the Samsung Development Team . :+1::star2::+1: