Galaxy 6 Classic no longer shows heart rate

My watch face shows 0 for heart rate even after rebooting. I just noticed this today; it did show heart rate previously.

Here’s the link to my faces: Birk Binnard - watch faces for Apple Watch, Samsung Gear S3, Huawei Watch, and more - Facer

Was there some sort of software change? I’ve got 2 faces and now they both show 0 for heart rate even though the watch measures and shows correct heart rate when I measure manually.

I tried 2 other faces that show heart rate and both show only 0. Could my watch be broken or have some sort of odd firmware problem?

1 Like

Your watch doesn’t have any problem, the problem is Google with its changes in the latest version of WearOS so that its pixel watch (which has very limiting hardware), has a more “decent” performance… that bug is occurring in all the faces with the latest Samsung (it does not happen on 4 and below) and the pixels, but Facer is working on an update to the application that corrects the error


Aha! Thanks for that excellent information. Everything you posted makes (sadly) perfect sense.

I remember when Google’s catchphrase was “First, do no evil.” Regrettably that was a long time ago.


It’s a few hours since my previous post - and now my face is showing heart rate. How can this happen? Is Google sneaking updated firmware into my watch?

I have not powered the watch off/on, rebooted, or anything since it showed 0 hear rate. This is most mysterious!

1 Like

A lot of People ar finding that it takes a bit of Time For the Voodoo to work . It would be Intresting to Hear an Explanation from a Software Engineer . At this stage in time it seems that it is all down to Luck . Like getting your Car going Properly by getting out and then getting back in again .
Thanks for the Good News .


Voodoo? Luck?? Are the inmates running the asylum here?

I appreciate your feedback Russell, and I’ve seen the post about step count being messed up. So there are clearly a number of serious problems with Facer and the Galaxy 6 firmware or software or whatever you want to call it.

Here’s another one:

The field of yellow dots is not visible to humans, but my Pixel 5a camera sure picks them up.

That’s my watch after powering on this morning. I usually turn it off overnight to save battery. Today this is what my watch did after it powered on. I’ve seen this a few times before, and I reported it to someone at Little Labs. It doesn’t always happen - sometimes the watch turns on properly. When this has happened in the past I was able to get my face back by switching faces to the one Samsung face I have in the watch, and then switching back to my face.

That did not happen today. Instead, when I switched back to my face, the watch got stuck on the Facer Companion face, and I could not get past that. I tried restarting - no luck. I tried rebooting - no luck. So I ended up clicking the little - sign on the Facer Companion face when I switched from the Samsung face to Facer, thinking that would delete Facer and my watch face so I could start over.

That did not work either, because when I went to reload Facer Companion it seemed like it was already loaded, and when I clicked on it my watch face came up ok, but (of course) with heart rate showing 0.

Maybe my heart rate will come back later today. Or maybe frogs will fall from the sky. Or perhaps the earth will fall into the sun. We are clearly in totally unknown territory.

Is anyone alive at Little Labs? Should I drive up there and knock on their door? (Actually there is no sign of Little Labs at the address they have - I’ve looked at the building on Google Earth.)

I sent my Galaxy 4 back to Samsung as a trade-in for my Galaxy 6. I wonder if they’ll give it back.

1 Like

I run my watch with very few faces on it . I am fortunate to have been able to make exactly what I wanted on my watch . Have a Clear out . I can show you how to clear the Cache if you like but not in public > I am delighted with my GW4 it is looking quite Battered now . I am thinking of making a Grungy army Face to match the Wear .

Ah yes, clearing the cache! Makes sense to me - I know what memory leaks are. I had thought that rebooting might do that, but apparently not.

My GW6 has only 3 faces (that I know of) - 2 of mine and one Samsung face. That doesn’t seem like a lot. But if there are apps with memory leaks - which I’m guessing is fairly likely - then clearing cache would definitely help.

Yet another reason to quote Ralph Cramden: “What a revolting development this is.”

1 Like

I will DM You .

Looking at your Face because you opened Inspection . Well Done . I see you have turned up the background to 100% opacity . I would turn it down . I always put my own Background in . The default always Worry me . Put a Rectangular shape layer down there 320 wide and high set to x0 y0 . It is entirely up to you but I would set my Hands above all the other stuff.

Thanks for your interest in my face. I wanted the background to have no active pixels, so I made it as black as I could. It’s not clear to me that opacity has any meaning when all the pixels are off, so I just didn’t mess with it.

As far as the hand Z-Height goes, I wanted the text to be as readable as possible, so I put that on top, The hands are just below that, and then comes the tick marks and numbers. It’s just a matter of preference I guess.

1 Like

Yes . It is easy to assume a New Maker has not thought stuff through . I can see that you have . You will note that the Background Default Opacity is 47% . I would love to meet the Software Engineer that set that and ask him / her why ?
I was just trying to see if there was a chance of a glitch that is showing that mesh on your Face .