Galaxy Watch 4 Classic face sync issue

I have a Galaxy watch 4 classic 46mm, coming from the Galaxy 3 that had no issues whatsoever.
I’ve even downloaded some older versions of the app, but it always wants to ask to either install the companion or make sure the companion app is installed.
I found one stupid thing in some other forum that worked, and that is completely closing out facer on my phone, then going to a face i want and applying the face, it works, but after that, it goes back to its same old nonsense with not seeing the watch.
Facer seemed to have worked MUCH better with Tizen on these watches, not sure if i cant stand Facer on Wear OS, or just Wear OS itself.

Please, any help would be so amazing.


I have the Galaxy watch 1st gen, the Galaxy watch 4 Classic and the GW 5 Pro. None of those are having any issues like you are describing. I would suggest you contact Facer Support by emailing them at: They will want you to include the watch brand and model number, the operating system version plus the Facer app version you have. Also include a detailed explanation of the issue you are having so they can investigate what might be going on.

1 Like

Ok sounds good, Thank you, I will email them and maybe wait for someone else with any leads.

1 Like

Not sure what’s going on but it has to work. You didn’t set something correctly.

  • do you have Facer installed on watch?
  • did you set Facer as current watchface (on watch)?
  • did you give all permissions to facer on watch and phone?
  • did you sellect (inside facer settings on phone) your new watch4?
1 Like

As far as I know you can only have one Watch Paired to Facer / Bluetooth . Go to your Bluetooth Settings and unpair all the watches you see there reboot your phone and start again . I would uninstall the companion app from your watch as well . Stick with it you will be very pleased when it is sorted .

I have three paired with my phone and all of them run Facer. I just make sure to select the watch that I am using with the phone that day in the Facer app, so that it functions correctly. I can get away using the GW5 Pro setting with my GW4 Classic but not with the Tizen GW1.

1 Like