FACER Community

Galaxy watch 4 is lagging when displaying time

Hi there, I just got my galaxy watch 4 yesterday and seems like it does really bad job when displaying the numbers since there are 2 layers of the numbers stacked up in the time displaying section of each watch face. I have tried many ways like uninstalling, soft/hard reset,… but the problem still persists. This only happens for the time displaying section, not the other parts of the watch face.
Here is a picture FYI Imgur: The magic of the Internet

1 Like

Welcome @rurihuynh. That is not Right. Not Fair on you. For now I would Switch off your AOD / Dim mode. I know there are Issues with that at the moment. It is not just Down to Facer. I know it will be sorted. A new OS was rolled out for that Watch and you and others are Beta testing it.
I hope that helps. There has been a lot of Chat on the Community about GW4 Wake issues. You could do a search or wait here till someone who has a Hard solution shows up.

If the time display was made with an outline (stroke) or glow effect that is not compatible with WearOS.

I also thought the problem is about the outline or glow effect, so I made a new version of that watchface using a different font without any effect. However, the problem is still there :smiling_face_with_tear:

The sad thing is I use neither AOD nor dim mode :smiling_face_with_tear:

I also tried the [Samsung wearble app>> All apps>> facers>> enable background activity] but for some reasons, I cannot enable the [background activity] button in my phone. It just does not move :upside_down_face:

1 Like

Oh I see it is a Watch you have Made… We are seeing similar problems in another Topic. Can you post an Inspectable link for the Face with errors. Remind us which Watch you have.

1 Like

It might also be the font you are using. Some fonts don’t work well in WearOS and some don’t work well in Facer. To do a process of elimination, change the font to one that Facer provides in the creator. That way if the problem goes away you will know it’s a font issue. If you will post the link to your face here with inspection turned on, we can look under the hood and see if we find anything.

I have two Galaxy Watch 4s the “Active” one and the Classic. I could turn on the background activity for my Classic but the regular GW4 is greyed out so I cannot change it in the phone app.

2 Likes

Here is my inspection link Facer - Thousands of FREE watch faces for Apple Watch, Samsung Gear S3, Huawei Watch, and more
Thank both of you for trying to help me :smiling_face_with_three_hearts:

1 Like

OK, I have an answer for you. I’ve synced your face to my Galaxy Watch 1st gen which is Tizen OS. I have also synced it to my Galaxy Watch 4 Classic and my Fossil Carlyle test watch which both run on WearOS version 3 for the GW4 and version 2 for the Fossil. The face displayed perfect on the Gen 1 but you can see the results below for the other two. I would say your font is the problem on any WearOS watch.

Galaxy Watch 4

Fossil Carlyle

2 Likes

Nice bit of MAGic . As you said just a matter of finding a font that works . I use the ones in Windows Copying them to a separate folder . The one where I have my hands and stuff.

2 Likes

I do the same thing; except any font I find that isn’t happy in Facer or WearOS I un-copy it from that folder. That way I know anything in that folder is good to go.

2 Likes

Those Freehand fonts are probably the worst. No mono spaceing there.

1 Like

That’s a sad thing to hear, so now I have to sync the fonts in advance to see if it works or not. I have used Facer for around 3 years or so with my Galaxy active 1, which is Tizen OS, and everything is perfectly fine :smiling_face_with_tear: Hope this issue will be fixed at some point in the future because I really don’t want my cute watchfaces having such serious vibe intervening its cuteness :smiling_face_with_tear:

Thanks a lot for helping me! I’m really appreciate that!

2 Likes

It’s not always the font that is the problem. I had trouble with what I thought was fonts for a year, until one day Mike O’Day discovered something:
Stroke and Glow do not work well. If you try either but set back to 0 it still messes everything up eventually. Do not touch Effects. When you create a watch face, leave Effects set to NONE. See if that helps.

3 Likes

I have a folder on my computer with tested fonts that all work with Facer and WearOS. It is in the main folder with my watch face information and dials and other parts. Like @Linlay says never mess with the Effects.

1 Like